1

I'm trying to build the GDAL's ECW plugin in Linux. I'm using the latest version of the SDK from Intergraph's site (5.0). It fails because it tries to compile against the 32 bit version of the library and not the 64. Here's the error message where the process dies:

/usr/bin/ld: skipping incompatible  
/usr/local/ecwjp2_sdk/lib/x86/release/libNCSEcw.so when searching for -lNCSEcw
/usr/bin/ld: skipping incompatible    
/usr/local/ecwjp2_sdk/lib/x86/release/libNCSEcw.a when searching for -lNCSEcw
/usr/bin/ld: cannot find -lNCSEcw

I have pointed ldconfig to look in /usr/local/ecwjp2_sdk/lib/x64/release, but that seems to be ignored. Is there any way to force it to look in the 64 bit version's directory, or can I get away with changing the symlinks for the 32 bit version and have them point to the 64's instead?

  • 1
    Have you seen this answer? – user2856 Nov 10 '13 at 0:10
  • Luke, thank you! I think I saw all the ECW related questions on this board but that one. Creating the symlink in /usr/local/lib did the trick! The compile finished just fine and QGIS opens the ECW file perfectly. – HeyOverThere Nov 10 '13 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.