0

I have been using the rule-based option to style some of the layers (from a postGIS database) in my qgis project. Then I put the project on the server and when I checked the WMS connection in QGIS, I only got the layers that were styled not using the rule-based option (i.e. categorized, single symbol). Does anyone have a idea why? Is the rule-based styling not supported on the server? Any hints where I could look for the problem?

I am using QGIS 1.8. Should I switch to 2.0 ? (I would prefer not to for several reasons specific to the project).

What I already tried: I checked the connection connection to the database – OK; I used a categorized styling for the layers that were not appearing – it worked, so not a problem with the layer itself;

1

It should work. The only caveat that I'm aware of and can be the problem here is to be sure there are no layers with the same name in your QGIS project. If you styled the other layers using the same name then this is it. I am using rule based styling with QGIS server 2.0 and there's to problem. All the best.

  • The layers all have different names, so that's not it. And since it's working for you @tudorbarascu with QGIS 2.0, I might try it or I'll have to look somewhere else for the problem. – Djana Nov 11 '13 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.