3

I have some exiting shape files that supposedly have a CRS of OSGEO:41001. If I import new data, and set the CRS to OSGEO:41001 they do not align. If I change the CRS of the new layers to EPSG:4326, everything appears to line up. While I can create pretty pictures, I can't do any distance or co-location calculations between layers. Apparently, I incorrectly transformed some data once in the past.

Starting for scratch, import old files (a base map of US) loads and displays. Screen coordinates for St George UT show as -12460233, 4682824. Load up new data consisting of Lat Long delimited text, the screen coordinates for St George show as -113.55, 37.02. Both layers have a CRS of EPSG:4326

Question: How can I fix my old files to be correct?

Question: What did I do wrong?

  • The -12million,4.6million values are probably EPSG:3857 aka web Mercator. – mkennedy Nov 12 '13 at 0:39
2

From http://wiki.openstreetmap.org/wiki/EPSG:3857 :

OSGEO:41001 - OSGeo created this code while developing the Tile Map Service (TMS) specification. [1] It was superceded by 900913. (equivalent, deprecated)

And by now, 900913 is replaced by EPSG:3857.

If you are in doubt over the right CRS, have a look at the extent of the data with Rightclick, Properties, metadata tab.

Coordinate in the range of +-21000000 are likely in EPSG:3857.

Coordinates in the range of +-180/90 look more likely as EPSG:4326 using degrees.

Other CRS in UTM metres or feet-US are also far greater.

In order to clean up your projection mess, do not reproject the old data with Save as.... You better assign the correct CRS to the data by Set CRS for layeror exchanging the .prj file with one that is correctly created for EPSG:3857.

The lat/long degrees data should remain in EPSG:4326.

  • With a new map and correct prj files, everything is working. Thanks – WombatPM Nov 12 '13 at 16:29
5

Tinkering with projections can be a bit difficult in QGIS sometimes. To be extra safe, my process is usually as follows:

  1. Open new map in QGIS and from menu bar select Project -> Project Properties
  2. Select CRS tab on left side of Project Properties window and check the box "Enable 'on the fly' CRS transformation.
  3. Choose appropriate CRS, apply changes, and close window.

If at this point your layers are still not lining up:

  1. Right click layer in Table of Contents -> Save As
  2. Select appropriate CRS
  3. Repeat for each layer in your dataset
  4. Close and reopen QGIS
  5. Set up on the fly transformations as described above
  6. Load your dataset

Sounds a bit clunky, but hey, it usually does the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.