1

I am having trouble uploading vector files onto GeoServer 2.4 using Import Vector in the QGIS Processing toolbox. After reading around about the 'REST' plus in I went to: http://<companyname)/geoserver/rest. However I got a 404 error as in it didn't exist even for existing files. I tried to run the same thing on my localhost and it worked.

Also when I run the tool I find an error code 404 in the log.

GeoServer is running on a company server along with Tomcat Apache 6.0

Could someone please tell me how to check the REST plug in, and if it is not installed how to get the REST plug in for GeoServer 2.4.0?

  • 1
    rest is built in these days (has been for a year or more) - most likely problem is a firewall or permissions to the server. – Ian Turton Nov 12 '13 at 14:20
2

The rest extension should be included by default for Geoserver 2.4.x. I can confirm that is the case on my 2.4.1 installation.
You can check to see if it's installed by looking in Geoserver's WEB-INF/lib directory on the server. If you see a file similar to 'rest-2.4.0.jar,' then it is installed.

You can test to see if it's working by navigating to the same URL as the web interface, except replace 'web' with 'rest' (in a web browser).
For example http://hostname:8080/geoserver/rest/.

  • Thanks for the quick response. I just checked and found I do have 'rest-2.4.0.jar', however when I check to see if it's working I get a HTTP 404 error. Does this mean that there is a firewall or permission error? Something with Apache configuration? Like what iant wrote. – Lutna Nov 12 '13 at 14:42
  • I would say it's likely some sort Apache configuration problem or (less likely) a permission issue. I don't think it would be due to a firewall, since you seem to be getting to the server OK. – Evil Genius Nov 12 '13 at 14:48
0

I can confirm the answer above,but in my case it regards to version Geoserver-2.8.SNAPSHOT (OpenGeoSuite), as follows:

Geoserver's WEB-INF: /usr/share/opengeo/geoserver/WEB-INF/lib/

I've get several JARs related to REST:

gs-rest-2.8-SNAPSHOT.jar gs-restconfig-2.8-SNAPSHOT.jar gs-web-rest-2.8-SNAPSHOT.jar ...

When I've tried http://localhost:9090/geoserver/rest server's response is a web page, containing:

Geoserver Configuration API: + imports + workspaces + namespaces + styles + layers ...

Hope this helps! Mirro.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.