9

I have previously asked a question on determining the area of polygons with another polygon boundary.

Determining the area of each polygon within a polygon boundary?

I came to the conculsion that using an intersect function was the most feasible option in determing the area of polygons within the 1000m boundary. Whenever I run an intersect with all the polygon shapefiles (there is about 40) within the Polygon boundary it generates an empty output.

I have set the coordinate system for each shapefile and the data frame to the same one. I'm using ArcGIS 10.1 with an ArcInfo license.

What would be the cause of this empty output generated?

WARNING 000117: warning empty output generated.

  • It sounds like you have been careful and did things right. One thing to consider next is whether there might be some problem in one (or more) of the shapefiles. A relatively quick way to find out is with a binary search: attempt an intersect of half (20) of the shapefiles. If the problem persists, continue recursively with half of them and so on. If the problem disappears, try the remaining 20, etc. Frequently you can home in on a single problematic input that is causing the errors; but even if you don't, you will have learned more about the nature of the difficulty. – whuber Nov 12 '13 at 15:13
  • Thank you, Whuber. That suggestion helps, it's definitely a process of elimination. – JC11 Nov 12 '13 at 15:45
  • 1
    I had the same error, but I noticed one didn't have a Projected Coordinate System. Once that was fixed it worked. (I wish ArcGIS would give better error messages to help identify what is causing the problem.) – user25402 Jan 2 '14 at 16:49
  • And I am 5 years late, had the same problem but the solution has been found from the developers themselves. :-) – Hezron Seya Nov 14 '18 at 11:29
5

Follow these steps:

  1. Visually verify that the polygons do indeed intersect using Arcmap
  2. Restart Arcmap
  3. Ensure that features are not selected
  4. Re-run the intersect
3

I was experiencing very similar difficulties, and tried repairing geometry with all files to no avail. What eventually worked was placing both files into their own file geodatabase, and then running the operation.

1

i'm 10 month late on this topic but my answer could help others :

A simple way around this is to export the shp your are working. The same tool applied on the exported shp might work just fine. to export : right click on the layer in the table of content --> data --> export data

0

I'm 4 years late here, but i faced same problem, and the solution was writing any value in xy tolerance! Maybe this will work for somebody else

-2

I faced same issue and tried the suggested solutions but none of them have been worked. However, I googled the problem and found the solution in Esri website. Check following website

http://support.esri.com/technical-article/000006932

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.