I simply want to create a buffer of a specific size, around a single point. When I create a buffer it uses degrees/ or radians, or whatever, and the buffer is created that covers the whole screen.

I am working on a South African map, so I have tried setting the project CRS to WGS84/UTM30S.

I then load my shapefile, and set the shapefile CRS to WGS84/UTM30S. Still the buffering tool creates this massive buffer.

I just want to be able to create a buffer, of known radius in meters.

I am using QGIS 1.8.0 Lisboa

Anyone with ideas?


I guess you have set the CRS for the layer in a false way.

If the data was originally in WGS84 degrees, you have to reset the CRS to that, then rightclick on the layer and Save as...

If you are in doubt, look at the extent of the layer under Properties, metadata tab. If it is in the range of +-180/90, it is definitely not UTM, but EPSG:4326, WGS84 degrees.

  • Hi. The metadata says: Layer Spatial Reference System: +proj=utm +zone=30 +south +datum=WGS84 +units=m +no_defs This would indicate that its CRS is WGS84 already – Liam Nov 13 '13 at 12:17
  • 3
    That might be manually set wrong. Just look at the extent values. – AndreJ Nov 13 '13 at 12:40
  • 1
    Just to add: WGS84 lat/long is not the same as WGS84 UTM! The first one has degrees as units, the last one metres. – AndreJ Nov 13 '13 at 15:36

What you need to do is right click on your layer and Save As. From the drop down menu then change the CRS and save the file. Load it back in and create the buffer again.

  • I tried that. Right click, save as, (CRS is already WGS84/UTM zone 30S), I add saved file to map, then try create the buffer with buffer distance of 200. And I get a massive buffer covering Africa. – Liam Nov 13 '13 at 11:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.