i have a raster file containing information about the windspeed average for the year. My purpose is to reclassify the 15 classes based on their rgb-composite. The color is the only information given. So i want something like this. A is my input raster.

A.1 == 255 && A.2 == 175 && A.3 == 176 = 1

And that i want to do with all different rgb-composite.

Any suggestions?

I tried r.reclass r.recode and the mapcalc from QGIS.

I am still struggling with this issue. It seems like there is a error that has nothing to do with the mapcalc syntax. I just tried a easy expression, like "A*100". I get the following error:

Problem loading output layer:

Oooops! The following output layers could not be open
Output raster layer: H:/reclassify/test2.tif
The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm

Checking the log information might help you see why those layers were not created as expected

This algorithm requires GRASS to be run. A test to check if GRASS is correctly installed and configured in your system has been performed, with the following result:

GRASS seems to be correctly installed and configured

I want to look at the log tab from the algorithm, but when the error appears i can't get access to the log tab. I only can close the error message and after that the r.mapcalc windows are closed too. So I am not able to mark any lines from the log tab.


1 Answer 1


Seems the bugs you mention with GRASS are a known issue with the standalone version. Nothing to do with mapcalc...

this was a packaging issue that has been solved on osgeo4w and now is just needed to wait for updated standalone installers. Réf : https://hub.qgis.org/issues/8529

Not the answer you're looking for? Browse other questions tagged or ask your own question.