1

I am working with the ModelBuilder tool in ArcMap. I have created a simple model that takes the Strip Map Index Features as an input. I have added fields to the model to produce more fields in the attribute table. When I run my model, it works as the original Strip Map Index Features tool should work, however, in the attributes table, I see my fields that I added, but they are not being populated / calculated.

I am not sure how to calculate / populate these fields?

I have searched around the net for solutions but am not getting too may concrete answers as I am still pretty new to using ModelBuilder.

  • 1
    Can you be a bit more specific - what are you trying to calculate in the fields? – Cindy Jayakumar Nov 19 '13 at 5:01
  • 1
    can you add an image of the model structure – user21053 Nov 19 '13 at 11:33
  • 1
    Can you not just add a CalculateField tool to the model and calculate the field? – dklassen Nov 19 '13 at 19:15
  • @arabella The Strip Map Index Features tool already generates some of these attributes in the table (Angle, PageNumber), so it would just be a matter of assigning those same values to the attribute fields that I've created (i.e., SMAP_ANGLE would get the values in Angle and SMAP_NUM would get the values in PageNumber).THe next case would be that SMAP_SCALE and SMAP_NAME would be populated from the inpute values. No major calculations for these attribute fields to be populated. I'm just not sure how to populate these fields that I've created. I've used the 'Add Field' tools. – user1898629 Nov 20 '13 at 15:04
  • 2
    We encourage self answering! A good answer is a good answer regardless of who is talking. Please add your solution using the answer section below (and then tick the check mark to acknowledge it as being the solution that worked for you). – matt wilkie Feb 6 '14 at 21:14
1

I was using ModelBuilder to create a tool for arcmap. I was basing my tool off of the Strip Map Index Features tool in ArcMap. I wanted to add extra fields to the attribute table. When my tool ran, I would look in the attribute table and saw that the fields were there, however, they weren't being populated with any values.

In my model, I had added the 'Add Field' tools but I hadn't added any 'Calculate Field' tools. Once I attached the 'Calculate Field' tools to my 'Add Field' tools, I was then able to open (double-click) the 'Calculate Field' tool to enter in a formula/expression/function. This helped add values to the fields in my attribute table.

0

This might be a solution for you!

http://resources.arcgis.com/en/help/main/10.1/index.html#//004000000004000000

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

0

I am not good at writing English but I want to share this problem and hope this answer can help you.

Using "Python" on (Calculate field tool) in ModelBuilder:

  • Python language: !shape.area@squarekilometers! use for Area squarekilometers
  • Python language: !shape.area@squaremeters! use for Area squaremeters
  • Python language: !shape.area@acres! use for Area in acres
  • Python language: !shape.area@hectares! use for in Hectares
  • Welcome to GIS SE! As a new user be sure to take the Tour to learn how the site works. Here the answer you are providing does not seem to address the specific question that was asked. – PolyGeo Feb 9 '15 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.