2

This question already has an answer here:

I load a delimited text layer and it get's visuialized. Unfortunatly I don't know why I can't switch to edit mode. I already worked with similar .CSV files in edit mode before, under the same setup :(

I already checked that files aren't write protected.
A workaround is to copy to a shapefile, but I like to work native with CSV.

marked as duplicate by underdark Nov 19 '13 at 18:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Which OS are you using? – G.Oxsen Nov 19 '13 at 16:26
  • Sry, Ubuntu 12.04. BTW the layer source is file:///.../residence_measurements.csv?type=csv&delimiter=;&xField=lon&yField=lat&spatialIndex=yes&subsetIndex=no&watchFile=no – Mapper Nov 19 '13 at 16:30
  • 1
    Never mind, I checked on my Mac, Windows, and Linux versions of QGIS 2.0.1 and they all do this. This probably means the answer that works for one version will work for all versions. I will play around with it today and see what I can come up with. – G.Oxsen Nov 19 '13 at 16:31
0

Ok, I have tried a few things now and this is the only work around I can come up with right now. I installed the XYtools plugin from the python plugin repository. I also installed the xlrd and xlwt python modules. From their I converted my csv file to xls using libreoffice calc. After installing XYtools you should see it in the vector operations menu and I import the xls file into QGIS as a using the ," Open Excel file as attribute table or point layer " option. I make my adjustments to the file as necessary. ( for my test I tried adding some points and deleting some points with the editing tools ) Then I used the field calculator to update the x and y fields in the layer so it reflects the position of the changes and then I save the edits and remove the file from the map canvas. The changes are updated in the xls file.

I know this is not exactly what you were looking for, however it is the best work around I can come up with that will allow you to work on a file in a simple format and save everything to a single file. I think bringing this issue to the attention of the QGIS devs is probably the best course of action to get a real solution to this issue.

  • The devs are certainly aware of this issue but it has to be fixed in the underlying OGR driver which QGIS uses to read an write vector data. – underdark Nov 19 '13 at 17:49
  • @underdark where is the proper place for me to voice my concerns and report bugs/issues regarding QGIS? I have found many places that I am capable of reporting issues but they do not seem to be part of the same group. I am still pretty new to the open gis scene and I am not sure how the whole project truly comes together. – G.Oxsen Nov 19 '13 at 18:13
  • The QGIS bug tracker is hub.qgis.org/projects/quantum-gis/issues. – underdark Nov 19 '13 at 18:25
  • There is already a request: hub.qgis.org/issues/9001 – underdark Nov 19 '13 at 18:26
  • @underdark Thanks for the info, it is appriciated. – G.Oxsen Nov 19 '13 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.