5

ArcGIS 10.0 take about 3 minutes to start. ESRI recommends doing these steps (http://support.esri.com/cn/knowledgebase/techarticles/detail/31672) but does not explain the consequences or adverse side-affects with respect to other installed applications.

I have also heard from a recent ESRI Seminar that decreasing the number of installed printers on the System will also improve start-up performance.

Can anyone comment.

My system is Win7 64bit 4gb Ram. No Licence server.

  • 2
    Uninstall ArcGIS? 10 ;) – Nathan W Nov 20 '13 at 8:21
  • 2
    Install Arcmap and/or your OS on an SSD drive? – Martin Nov 20 '13 at 8:22
  • Can you provide add details about your computer's specifications? We would be able to comment based on that.. – Chethan S. Nov 20 '13 at 9:08
  • 1
    If you have a bad connection to the license server that can make things very slow. Note that license servers is not needed with open source software :-) – Nicklas Avén Nov 20 '13 at 9:32
  • 1
    Delete your normal.mxt periodically. Also, you can watch the splash screen to see which step in the boot is taking the longest in order to narrow down the issue. – DPierce Nov 20 '13 at 19:29
6

This link will take you to a much more comprehensive ESRI approach to the issue:

http://blogs.esri.com/esri/supportcenter/2012/06/07/troubleshooting-slow-performance-in-arcgis-desktop/

2

By default, Arc connects to ArcGIS Online on startup. There's a setting to disable this, but I don't remember where that is. That can dramatically speed up start time, but then you don't have the basemaps there. At least this is the case in 10.0 and before. ESRI also recommends your folder connections be as close to the actual data as possible, because, I think I read, it has to verify the path to subfolders.

  • 1
    I don't think there was a straightforward way to disable this in 10.0, but as of 10.1 it can be done by right-clicking the ArcGIS Online icon in the Windows notification area/system tray and opening the Properties window. There's an "Enable" checkbox that's on by default. – nmpeterson Nov 21 '13 at 18:17
0

We have had a ton of troubles with ArcGIS 10 .mxd's opening slow and then performing poorly. We received this advice from a friend who now works for esri and it has helped solve the problem.

Close all ArcMap Sessions.

In a Windows Explorer window browse to: c:\Users\xxx\AppData\Roaming\ESRI\Desktop10.0\ArcMapTemplates\Normal.mxt

Rename the Normal.mxt to be Normal_old.mxt

Open a new ArcMap Session and a new Normal.mxt will automatically be created.

Close the new mxd.

Delete the new Normal.mxt

Rename the Normal_old.mxt to be Normal_mxt.

  • HI...Thanks...but it didn´t make any difference to my start time. – Robert Buckley Nov 22 '13 at 6:09
  • "Rename the Normal_old.mxt to be Normal_mxt."??? do you mean Normal.mxt or Normal_mxt.mxt? – Robert Buckley Nov 22 '13 at 6:10
0

I found some operation helpful to this question.

  1. shortcut "win+R", and type "regedit", hit "enter" key, to open the regedit window.

  2. find "HKEY_CURRENT_USER\SOFTWARE\ESRI\Desktop10.2\", delete the "ArcMap" folder.

  3. open ArcMap, the folder will be recreate.

following these steps can delete all the user specific settings, ArcMap will be fast again as you first time installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.