2

I'm trying to delete a feature class from a feature dataset or to add a field to it, but I keep getting an error message (pics attached below). I have imported a geometric network I've created from one PGDB to another. However couldn't add any fields. I'm receiving the following error:

enter image description here

Than I planned to delete the feature classes that were imported - I've received the following error:

enter image description here

I have the feeling that both errors are related but couldn't figure out the problem from ESRI help or from other posts in gis.stackexchange.

4
  • 5
    Have you tried closing all ESRI applications? Then only start the one where you will do the editing. If no changes, also try to restart your computer.
    – Martin
    Nov 20, 2013 at 8:24
  • It worked (deleting), Thanks . I understand that it is just a bug?
    – dof1985
    Nov 20, 2013 at 8:45
  • 5
    Sometimes there are (legit) locks on files you try to edit, because they are open in, say, ArcCatalog. However, it happens that the locks are not properly released when the file is no longer open in that other application. This happens to me almost every day, and the fastest solution is to close all applications.
    – Martin
    Nov 20, 2013 at 8:56
  • Once you add a feature class to a project, even if you immediately remove it, it is likely it is locked until that thread of ArcMap is closed. If the feature class is in a feature dataset with a topology it is possible all the dataset features will similarly be locked. The separate program version of ArcCatalog can lock or suffer from locked files in ArcMap too but the ArcCatalog tab in ArcMap will in many cases allow you to do things like delete or rename features even when they are still in ArcMap.
    – John
    Dec 4, 2013 at 14:25

3 Answers 3

8

Close all ESRI applications. Then only start the one where you will do the editing (eg. Arcmap).

This will release all locks that are on your data from other applications, which are interfering with your data manipulation.

If it still doesn't work, also try to restart your computer.

1
  • 1
    Sometimes Arcmap has a hung process, perhaps after a failed geoprocessing tool, even if there are no visible windows. After you close all Arcgis applications, run Windows Task Manager and open the Processes tab. Force close any ArcMap.exe or ArcCatalog.exe processes. (ArcGISConnection.exe and ArcGISCacheMgr.exe are ok to leave running). Apr 3, 2014 at 17:40
0

Sometimes Arcgis maybe corrupted or need to update latest service packs or patches

15
  • My version just been updated to 10.2 few days ago
    – dof1985
    Nov 20, 2013 at 10:03
  • I had same problem while released arcgis 10. After sometime I have updated some patches and then problem has been solved.
    – Venug
    Nov 20, 2013 at 10:07
  • Please check in your GEO - Database is there any topology rules added with that feature class or any link between two feature class.
    – Venug
    Nov 20, 2013 at 10:10
  • I havn't found any topology rules. I only planarized the layer using the advanced editing toolbar. What do you mean by link between feature classes?
    – dof1985
    Nov 20, 2013 at 10:18
  • Means that relationship feature class
    – Venug
    Nov 20, 2013 at 10:21
0

Please try to open Access table and delete unnecessary field or change data type PGDB to shape file and delete field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.