I got my GeoServer up and tried to published my layer.

I have my own shapefile and I follow the document below to add new layer intend to publish it.

geoserver shapefile-quickstart doc

Referring to the document, it shows the below 4 steps:

1) Create New Workspace
2) Create Store
3) Create Layer
4) ***Layer Preview***

I am having problem on the last step: Layer Preview. When I access to the Layer Preview in GeoServer, I did not see my added layer in the preview list.

What could be the possible reason for the above problem?

I am new to GIS and new to GeoServer.

1 Answer 1


When you are publishing/Editing the layer in the web interface, go to the 'Publishing Tab' and Under Edit layer check the Advertise check box.

If this is enabled, then you should see the layer in the Layer Preview.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.