4

I am trying to publish a map service containing a cached raster layer on our ArcGIS Server Enterpise 10.1. I analyze the map service before publishing and no error.

The error I get when publishing is:

The service has been published successfully. The cache for the service has been enabled but the cache generation failed."

See attached image enter image description here

Further details:

  • the GIS Server and the folder are on the same machine, with Windows OS.

  • we're talking about a virtual machine in the cloud.

  • the raster layer is created from a mosaic raster in .tif format (size= 1,5 GB).
  • I use ArcGIS Desktop 10.1
  • I am trying to create a 5 scale cache.

PS: Found the error on esri forum, but it's for ArcGIS Online servers: http://forums.arcgis.com/threads/60488-Error-Publishing-a-Map-Service-for-ArcMap-to-ArcGIS-Online

Thank you in advance for your help.

  • 1
    Can you check what is going on in geoprocessing Results log as well as Server log (in ArcGIS Server Manager - set it to Debug and try to publish with the caching option on). Then check the logs again to see if there is any useful information on that. PS. Can you control that the CachingTools system service is up and running on that machine? – Alex Tereshenkov Nov 25 '13 at 7:19
  • Hello,10x for the quick reply first of all. In GP-Results the message is "Error 001276: Invalid number of Cache GPService instances specified. The tool takes a minimum of 1 instance". How do I increase the number of instances to work on a caching job? – Ligia Nov 25 '13 at 8:57
  • are you sure you have copied the error message correctly? Have not seen exactly this error message before, and cannot find it on the Internet either. My suggestion is to go to System folder in the the server connection (Catalog window in ArcMap) > right-click CachingTools > Processes tab > set 3 for minimum number of instances. See what happens when you try to publish a service with the caching enabled. – Alex Tereshenkov Nov 25 '13 at 9:44
  • The problem was simpler than that:) The CachingTools service from the System folder was stopped:) Don't know why, but anyway, you sent me to the right track. so thanks. Please provide an answer so I can give you the bounty:) – Ligia Nov 25 '13 at 11:59
  • Glad we nailed it down :) – Alex Tereshenkov Nov 25 '13 at 13:11
2
+50

Since 10.1, there are two special system geoprocessing services that are called CachingTools and CachingControllers. These services are available in the System folder under the GIS Server connection. These services are responsible for starting and managing caching jobs. In order to be able to start caching a service, these services have to be started. From Esri help:

The CachingControllers service helps process map, image, and globe caching jobs. The maximum number of instances you allow for this service determines how many cache jobs can run at one time. The CachingControllers service works together with the CachingTools service. Both must be running in order to build caches. Both must run on the same cluster.

  • I'm back:) SO I managed to publish a small test-raster but when I try to publish my 30GB one the cache status gets stucked at 0% or 0,16 %. Should I start another topic or do you think is related? – Ligia Nov 27 '13 at 10:39
  • I think it is best to start a new question. I also strongly suggests reading through the help a bit and start with caching a smaller dataset, maybe 100MB or so to see that caching works fine. The CachingControllers service works together with the CachingTools service. Both must be running in order to build caches. Check that you have enough space on hard disk (you are on Amazon? check that the partition you have arcgisserver folder has enough space). – Alex Tereshenkov Nov 27 '13 at 10:50
  • i've tested the caching service with a 1GB raster and it worked fine. we're on a Microsoft Azzure Cloud. there isn't much space left (42GB) in the partition where arcgisserver is but I chose another directory (larger) for storing the cache. Anyway, you are right. I'll read the help again and start a new topic. Thanks again. – Ligia Nov 27 '13 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.