I would like to add xy coordinates of about 10 sites to a raster. I am using ArcGIS 10.1 and my xy coordinates are on Access 2013 database - saved as .mdb.

The steps I have taken so far:

  1. In ArcCatalog - I tried making the OLE DB connection - Microsoft Jet 4.0. OlE Provider - when i clicked 'next' it says the connection is a 'success'

  2. Then I clicked on the Database Connections on the arcCatalog tree, clicked on the 'OLE DB connection' and the table appears to be ok on the 'preview' screen. However when i click on the 'Description' section there is the error message: 'The item's XML contains errors' - I don't know what this means.

Anyway, I right clicked the table under OLE DB connection (on the arcCatalog tree) - clicked 'create feature class' - 'from XY'Table (i also put the right coordinate system - which is the British National Grid).

  1. After that, I opened ArcMap. Added the DEM Raster (which also has the same coordinate system) and the XY feature class I just created.

But the problem is I cannot see the sites (the dots).

enter image description here

I have successfully done this in the past but for some reason I just can't seem to get it to work this time. The following picture shows how I want it to appear:

enter image description here

I have also tried the other way: ArcMap - file - Add Data - Add XY data. And then right clicking the layer and clicking 'Data' - then 'Export data' to create a feature class.

A couple of weeks ago I did have a new version of Microsoft Access and excel installed ( the Microsoft office 2013 plus). I don't know whether this has something to do with it or whether I have simply missed a crucial step.

  • Do you get any error messages when you do it via Add XY data? Are you sure you have set X to X coordinate and Y to Y coordinate and not vice versa? Check the coordinate system of the data frame also.
    – reima
    Mar 9, 2015 at 10:59

3 Answers 3


the raster data and the shape file still don't share the same extent, there is another way to export the projected raster data with sharing the same extent like your point data. Save it for a New raster data as a tiff file. and this New raster data would have same extent as your shape file. hope it works.


You could try right clicking on your XYSites feature class and selecting "Zoom to Layer".

If you can see them, and they are not overlapping your raster coverage, you have a Projection problem.


In the question, you state that the coordinates are in Lat/Long, but you later say that you define the coordinate system of the file as being British National Grid.

Perhaps you have defined the file as BNG (a projected system) when the data is actually in a geographic format.

This might explain the points not showing up anywhere in the data frame.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.