we're using qgis-web-client to present our maps publicly over the net. I haven't worked with it a lot so I'm still playing around with it a bit. One thing I do not understand, yet: When qgis-web-client opens I just see a blank screen because the extents are not set correctly.

But how do I change them?

I also set var useGetProjectSettings = true; so actually qgis-web-client should zoom to the correct extents by default.

It's quite annoying to always click on the icon in the middle of the navigation arrows and then zoom to the correct location.

  • Can you share a link where we could see your qgis-web-client installation running?. – jgomo3 Jul 4 '14 at 19:52
  • 1
    Of course, this is an example map that works now: assip.project.tuwien.ac.at/maps/SHIAE_SSOND11 . But there are still a lot of issues I was not able to resolve yet so please don't see it as a finished example. – niklaas Jul 4 '14 at 20:31
  • That's great. Thank you!. How is your architecture implemented? qgis-web-client/Geoserver/Postgis ?. I'm working in something the same, but instead of qgis-web-client, i'm working in a custom "view" with the opengeo-web-sdk. I didn't know about qgis-web-client. – jgomo3 Jul 5 '14 at 13:48
  • 1
    To be honest, working with the qgis-web-client is my first approach in WebGIS. So I heard of and played around with the software you mentioned but I am not very familiar with it. In my opinion, qgis-web-client just lacks documentation. But since I am doing this work in view of a research project there will be a paper documenting the exact way how I implemented the maps soon. Just send me an email and I can send you the PDF when it's finished. Answering your question: I just installed the QGIS Server application and git cloned the qgis-web-client. – niklaas Jul 5 '14 at 16:52
  • @niklass: Good. My email is the same as my username here, but <at> gmail. I'll be glad to read it. – jgomo3 Jul 6 '14 at 22:33

After finally finding this conversation http://lists.osgeo.org/pipermail/qgis-user/2014-February/026220.html I changed the used CRS of my project to the one as stated in GlobalOptions.js: var authid = "EPSG:"+3857;. (Unfortunately, the CRS I would like to use is not available in site/libs/proj4js/defs/. Manually creating it also did not help.) Additionally, I also had to include the CRS in CRS Restrictions in the Project Properties of the project file and "Use Current Canvas Extent" in Advertised Extent. Now, the initial view is the same one as in the desktop application. Heureka!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.