16

I open a new composer and select ANSI A for my paper. The notation after the name is "Letter; 8.5inx11in", but the width and height are displayed in mm, and the units selection is grayed out, so I can't change it. The rulers at the top and left of the layout are in mm, and the parameters for "Snap to grid" are also in mm. If I then select "Custom", I can select inches for units, and the Width and Height display as 8.5 and 11. However the rulers in the layout are still in mm, as are the units for the grid.

Can the entire composer project be converted to inches?

qgis 2.01 64 bit
windows 7, 64 bit

0

5 Answers 5

6
+50

You can't (as of 2.12). The "units" selection in the composition properties tab only changes the units for the display page size. Everything else is hardcoded to use mm (ie rulers, item positions, item sizes, etc).

2

It looks like this problem is fixed in QGIS 2.8.1 : enter image description here

Are you able to reproduce this?

2
  • 3
    I am having the same issue as above, and have not been able to reproduce your answer. In my installation, choosing a paper size in inches only changes the presets box. The width, height and units are all still in 'mm', and the units are locked and grayed out. Commented Oct 28, 2015 at 23:13
  • 1
    This answer is incorrect- it only applies to the page size, not any other settings like guides.
    – ndawson
    Commented Jan 4, 2018 at 20:30
0

If you want to change units of a page size to inches, select the page size you want, then switch the page size to Custom, which allows you to change the page units to inches. Then when you switch back to the page you first selected, it will display its size in inches. If you change the page size, it will remain in inches.

Although I haven’t tried it, you can probably skip the first step.

As far as I know, there is no way to set all layouts to default to inches. I’m using the latest version (3.24) and checked. This is especially annoying with the rulers, which will only display in mm.

0

I found this blog post to be helpful. Basically it involves saving a layout template (.qpt) file and editing it with a text editor, replacing "mm" with "in". If you save the edited template in the "composer_templates" directory under your profile e.g. /home/rich/.local/share/QGIS/QGIS3/profiles/default/composer_templates it will be shown in the Layout Managers "New from Template" list.

-4

This is possible in QGIS >= 3.0.

3
  • 4
    What are the steps to make it happen? I can't figure it out in 3.14 Commented Feb 26, 2019 at 21:16
  • 1
    Please explain how to do it in QGIS 3.0 and above. Commented Dec 17, 2019 at 14:25
  • @ndawson Yours could be a very valuable answer if you detail the steps necessary to convert the units;)
    – Aaron
    Commented Apr 11, 2021 at 16:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.