1

I'm trying to publish a map service containing a large .tif raster (48GB).

I managed to publish a small cached raster successfully (for testing), but when I tried to publish the large one, the cache generation got stuck at 0% even though it kept saying it's in progress, and again at 24%. Now I can't even publish the small one because the application is not responding right after I select "Publish".

Details:

It's an ArcGIS Server Enterprise 10.1 on a Windows Server 2008 OS machine.

  • the machine is on a Microsoft Azzure cloud.
  • the machine has 4 CPU cores (so I set the number of instances to 5).
  • it's a raster TIF file with LZW compression.
  • I chose 5 scales, and tried different formats for the tiles.

enter image description here

Thanks for your help

  • 1
    You need to include more info to be able to diagnose this. Do you see any of the SOC processes in task manager ticking away using CPU? Whats going on the ArcGIS Server logs when set to verbose? – Simon Dec 1 '13 at 1:01
  • Hello, I've attached a picture. It seems that the SOC processes are not using the CPU. – Ligia Dec 3 '13 at 15:03
  • 1
    You have a 48GB tif? It's my understanding that tif and geotiffs files are limited to 4GB in size. digitalpreservation.gov/formats/fdd/fdd000279.shtml – nickpeihl Dec 5 '13 at 5:07
  • 1
    If it's a high priority task, I'll recommend getting touch with ESRI support services. – Devdatta Tengshe Dec 5 '13 at 8:42
  • contacted ESRI. can't really say what was causing that behavior but apparently a new arcgis server restart solved the problem. I have to see if the behavior repeats, otherwise I would have to say that the solution is simple: restart the machine, restart arcgis server. – Ligia Dec 5 '13 at 9:02
1

I had the same problem, the only solution that I found was to recreate the MXD, it's probably that you have a layer definition or symbology problem.

Try recreating the MXD and try republishing the service.

  • tried that. didn't work. – Ligia Dec 11 '13 at 8:31
1
+50

I also had the same problem. Sometimes you can not restart the machine.

  • You can "fix" this problem if you set "create tiles on demand" (in ArcGIS Server)
  • Also you can use tool "manage map server cache" (if you have ArcMap). Here you can select layers for generating cache.
1

There are two issues that might cause the original question: 1. the soc account does not have access; 2. there are too many of the files

Please make sure that the tiffs are located where the soc account has access to-> republish the service->delete the cache folder ->recreate the cache

You can try with all the tiffs in one map document. Also recreate the mxd file is a good option.

Here is a Cache Validation Tool if it is necessary to check: http://resources.arcgis.com/gallery/file/enterprise-gis/details?entryID=632A4F2B-1422-2418-34C2-3BC3E9F063ED

  • soc account did have access to the folder. thanks for the link though. it will be useful in the future. – Ligia Dec 11 '13 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.