1

The OpenGeo Suite 4.0 has some issues with dependencies specifically with respect to GDAL and PostGres libraries.

The issue arises when one tries to install libgdal-dev, which is required, among other thingds, to get ECW reading working.

I tried installing the OpenGeo Suite 4.0 on a fresh install of Ubuntu Server 12.04, and also tried an upgrade from the 3.2 version of the suite. Here's a pastebin of the error from Apt: http://pastebin.com/3BqZVvCn

After an upgrade, ECW's can't be used, event after installing the extensions into the GeoServer's WEB-INF/lib folder. ECW appears as a format, ECW is listed by GDAL as available, creating an ECW store works, but the store is always empty... Valid stores that worked in 3.2 dont' work on 4.0.

A secondary issue is that some file permissions seem to be broken on upgrading from 3.2 to 4.0, these are exhibited by failure to load some aspects of the GeoServer interface, such as logging.

Does anyone else have these issues, and if so, are there any known work-arounds? It seems to me that a resolution would be for Boundless to add in the missing packages to their repository, but that may be naive.

  • The issue with gdal and geoserver is a known one. Boundless will be releasing updated packages soon that should fix this issue. It will however still mean that you will need to use the gdal packages provided from the boundless/opengeo repository. The package updates will include a libpq-dev package. – jdeolive Dec 2 '13 at 23:37
  • Hi @jdeolive, will the packages include the needed packages for building ECW support? This post explains the current method for achieving this. If Boundless included the required packages that UbuntuGIS include then that would be ideal: gis.stackexchange.com/questions/27247/… – Alex Leith Dec 3 '13 at 0:43
  • We don't target ecw specifically because of the license but reading over the past you linked to I believe it should be possible. Regardless I will pass this onto our packaging folks. – jdeolive Dec 3 '13 at 15:58
  • I still can't get this to work, @jdeolive. I just started afresh, new install of Ubuntu, new opengeo suite... I think that Boundless should include libgdal-ecw-src, so that I don't get the conficts in packages between ubuntugis and opengeo-suite – Alex Leith Jan 29 '14 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.