4

I have a set of 357 rasters in .jp2 that I've added to a mosaic dataset. All but 7 of them display properly, but the 7 only display at larger scales, around 1:6500 and under. I've tried adding them several times, deleting duplicates, overwriting, building overviews, etc., but can't figure out how to get the 7 to display normally like all the rest. Any clues?

Using ArcGIS 10.0, sp5, Windows 7 Enterprise.

  • Have a go at rebuilding pyramids and statistics for the individual rasters then do the same for the mosaic dataset, you may need to rebuild the overviews for the mosaic dataset – Hornbydd Dec 3 '13 at 21:58
  • Thanks. I rebuilt pyramids and statistics for the rasters, and overviews for the mosaic dataset. No luck. I don't see a tool to rebuild pyramids or statistics for the mosaic, though. – recurvata Dec 5 '13 at 17:29
2

Fixed with ESRI support. Took the bad rasters, put them in their own mosaic, then added that to the original. Don’t know why it happened, but oh well.

  • "Don't know why it happened..." Ah yes, I've heard that a few times. Right up there with "I restarted the computer and it worked fine." ;) – user23715 Oct 9 '15 at 20:08
0

A few ideas:

  • Check to make sure the coordinate systems on the 7 .jp2 files exist, defined and the same as the other raster datasets. Right-click layer > Properties > Source > Spatial Reference.
  • Make sure the scale range is not set. You can access the layer Properties by right clicking the layer > Properties... > General.

enter image description here

  • Thanks Aaron. They all seems to be consistent with the ones that do display. They also display fine as stand-alone rasters, it's just in the mosaic dataset that they don't display. – recurvata Dec 3 '13 at 20:35
0

I was having the same issue: One raster in a mosaic of ~ 20 rasters wouldn't display when zoomed in past 1:2,000,000, which would result in NoData for this tile when I would perform raster calculations. I tried adding the bad raster to its own mosaic and then adding that to the original, which allowed the bad raster to be displayed at slightly larger scales, but would still not display when zoomed in past 1:600,000. The following finally worked:

  1. Remove all rasters from original mosaic dataset
  2. Add bad raster first
  3. Add remaining rasters
0

Had the same problem (in ArcGIS 10.4). I added some rasters to a mosaic dataset and the new rasters would only appear when zoomed way in.

Here's how I solved it:

In ArcCatalog Right Click the Mosaic Dataset > Optimize > Build Overviews, checked all 4 options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.