2

I have just installed ArcGIS for Server 10.2 on my server and the publishing services will not start. Has anyone had issues with this before? The error message that I receive after the service fails to start is:

Service failed to start System.PublishingTools.GPServer: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: java.net.SocketException: Connection reset

If anyone has some insights it would be much appreciated.

  • Did you got any solution for this I am also experiencing same problem Regards – user29665 Apr 28 '14 at 21:35
1

I'm a french GIS guy, so sorry for this english but perhaps I have a solution for you.

Can you look at the Windows registry path at: HKEY_LOCAL_MACHINE\SOFTWARE\Python\PythonCore\2.7\PythonPath. The value should look something like:

C:\Python27\Lib;C:\Python27\DLLs;C:\Python27\Lib\lib-tk

You must have this string value in your registry. So if it don't exist you must to create new one with the same characteristic key string.

Test this if you want and it's for nothing, goodluck.

  • 2
    Rico, I solved my issue by disconnecting all of the SDE connections/users and then restarting the service. For some strange-ESRI reason that was all it took. – Winston Jan 24 '15 at 0:01
  • Thanks Lieg. I also faced this issue, once i edited the registry, it worked fine. – vadivelan Mar 10 '16 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.