1

I have just installed ArcGIS for Server 10.2 on my server and the publishing services will not start.

Has anyone had issues with this before?

The error message that I receive after the service fails to start is:

Service failed to start System.PublishingTools.GPServer: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: java.net.SocketException: Connection reset

0

1 Answer 1

2

If you look at the Windows registry path atHKEY_LOCAL_MACHINE\SOFTWARE\Python\PythonCore\2.7\PythonPaththe value should look something like C:\Python27\Lib;C:\Python27\DLLs;C:\Python27\Lib\lib-tk

You must have this string value in your registry. So if it does not exist then you must create a new one with the same characteristic key string.

2
  • 2
    Rico, I solved my issue by disconnecting all of the SDE connections/users and then restarting the service. For some strange-ESRI reason that was all it took.
    – Winston
    Jan 24, 2015 at 0:01
  • Thanks Lieg. I also faced this issue, once i edited the registry, it worked fine.
    – vadivelan
    Mar 10, 2016 at 8:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.