0

I've just upgraded to QGIS Dufour and I am having some problems with the exportation of a simple track from .shp to .gpx and .kml format. I imported from mi smartphone a .gpx track (SR WGS84 EPSG:4326), i converted it into .shp (EPSG:3857 in order to have it correctly projected over the google maps layer); I modified it and I finally need it to be exported into .gpx and .kml formats.

For .gpx: I did the "Save as", chose GPX format, set the RS to EPSG:4326, wrote "GPX_USE_EXTENSIONS=YES" in the Data Source field and "FORCE_GPX_TRACK=YES" in the Layer field. Qgis says it all went ok (and it loads the track in the viewer and it looks fine), but when I load the .gpx track into my gps device I only see a straight line into the sea.

For .kml: I did the "Save as", chose KML format, set the RS to EPSG:4326. Qgis says it all went ok, but when I load it in the viewer it looks just empty and in google earth I can see a huge red cross over Africa... and I was looking for a road in Sardinia.

Can anyone help me, please? Thanks a lot!

  • 2
    If you add the gpx or kml to the canvas again, what extent is reported by Rightclick->Properties, Metadata tab? – AndreJ Dec 4 '13 at 16:35
  • The extension of the gpx layer is correct, while the one of the kml is blank. – SaraZanni Dec 4 '13 at 18:18
  • Can you try with Surpress Attribute Creation? Maybe the GPS device does not like the extensions. – AndreJ Dec 4 '13 at 19:41
  • Where should I find that option? – SaraZanni Dec 5 '13 at 9:34
  • 1
    In the Save As...Dialogue. In Englsh locale it is skip attribute creation. – AndreJ Dec 5 '13 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.