1

I have two layers, one point file and one polygon. The point file is in WGS 84 and polygon in NAD83-UTM10. The project CRS is NAD83-UTM10. They project fine with on-the-fly projection turned on. I want to clip the point file with the polygon, and understand that all layers need to be in the same CRS to enable clipping or other ftools functions. When I change the CRS of either layer to the other (changing the point file to NAD83 for example), it projects far away from where it was (ie. doesn't line up). This is the same if I right click to change the CRS or if I "save as." Same no matter which CRS I select. I'm running QGIS 2.0.1 Dufour on Mac.

Any help would be greatly appreciated! Thanks!

  • 1
    You need to save the layers using the same coordinate system. Just setting the CRS in the layer properties is not enough: you're just telling QGIS how to interpret the coordinates of the layer, you're not actually reprojecting them. – Jake Dec 4 '13 at 18:48
  • Thanks Jake. Would that be right clicking on the layer, choosing "save as" and specifying the CRS at that time? I tried that as well but the resulting new layer had the same problem. – KMT Dec 4 '13 at 18:55
  • Yes, that's the procedure that should work. If you save the point layer as NAD83-UTM10 using that method and then open the saved layer, do the points appear in a different location? – Jake Dec 4 '13 at 19:02
  • They appear in the same place as they do when I just set the CRS to NAD83-UTM10 - in a different location from the polygon file that I want to use to clip (and which usually overlays when on-the-fly is turned on and when they have different projections). Basically, when I either set the CRS in layer properties or save as a new layer to NAD83-UTM10, the two layers move far apart. – KMT Dec 4 '13 at 19:22
  • 1
    I understand that on the fly works for projecting it visually, however it does not work to complete a clip with these layers and otf projection turned on as they are in different CRS. At least that's my understanding. When I do run a clip function, the output file is empty. – KMT Dec 4 '13 at 19:34
2

For advanced geoprocessing tasks across several layers, it is always best to turn On-the-fly reprojection off. Then you see if the layers align or not.

Perform reprojection using Save As... on all layers that have a different projection, add the result to the canvas, and remove the old layers from canvas. Otherwise you might still catch the wrong layer, and clipping will result in nothing.

Your point data is rather big, but succeeded at last:

enter image description here

  • Thank you! Not sure why this didn't work for me before when I tried it, but it is working now. Perhaps I didn't delete the old layer and might have grabbed it by mistake as you suggested. I really appreciate the help. – KMT Dec 6 '13 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.