Not sure what the issue is, but I'm unable to get labels to display in ArcMap 10. The obvious things are accounted for (as far as I know). Labels are set in Properties, layers are checked to label in the TOC.

I've even restarted to see if that would work.

UPDATE: 3/3/2011

After trying all of the mentioned solutions, I was still unable to get labels to display. It wasn't specific to a single layer, but rather to any layer in the .mxd.

I opened a new document, added the layer I'd been trying to label, and was able to display labels just fine.

What may have caused the initial document to globally make labels not display?

  • 2
    have you tried other features and shapefiles to make sure its not related to the data rather than the application?
    – badkins
    Mar 31, 2011 at 11:21
  • the below suggestions pretty much cover all of your first check things when labelling won't work. The only other thing I would do would be to switch your labelling engine (if it is maplex go to standard and vice versa).
    – badkins
    Mar 31, 2011 at 12:50
  • Is this for one particular shapefile (or mxd) or labeling of any shapefile in ArcGIS?
    – djq
    Mar 31, 2011 at 13:28
  • 1
    I had the same issue with a simple solution. Place your labels while you are in View, not Layout.
    – user8542
    Jun 29, 2012 at 15:48
  • I believe it is a spatial reference issue.
    – user15747
    Mar 4, 2013 at 12:00

14 Answers 14


One more thing that took me a while to figure out is to make sure there aren't any graphics blocking your labels. Do this by going into your Data Frame Properties and the Annotation Groups tab to turn off all annotation groups. If your labels appear now, it's because a graphic was blocking the rendering of the feature label. Converting the labels to Annotation is the only way I've found to make the labels appear over top of graphics.

It seems the graphics engine in ArcGIS isn't smart enough to determine that a diagonal line only takes up a one dimensional space. Instead ArcGIS draws a rectangle big enough to encompass the diagonal line, causing any feature labelling that is overlapped by this big rectangle to not display - even when the line itself isn't overlapping the labels.

However, this artcile explains how to fix the issue. For ArcGis 10 see the label weight ranking tool


Some things to try:

  1. Add the featureclass or shapefile to map again, don't move it into a group layer, don't set any scale ranges and turn on labels. This will tell you if there's something wrong the data or if it's your layer configuration.

  2. Check to see if you are using label classes and if you are, check the SQL query for the label classes(including Default) and make sure that you are returning records. (If there's no records, then there's no labels). I've seen users write a "correct" SQL statement that doesn't error--it just returns 0 records.

  3. Check the scale range and see if you have a scale range set--you might be outside the range needed for labels.

  4. Check the parent/grandparent group layers and make sure they are checked on. Also check their scale ranges.

  • 2
    Also, sometimes when it happens to be a polygon layer (i.e. sections) I have seen it not label until I tell it to "never remove"
    – Brad Nesom
    Mar 31, 2011 at 14:15

I believe I just had the very same problem as you, labels did not appear at all in the mxd, but showed if I moved the layer to another mxd.

I solved it by checking the Label weight ranking in the Labeling toolbar. In the layer/label list there was a layer called at the very top that had Feature weight set to High but Label weight set to N/A. After I changed the feature weight to None, the labels appeared correctly!

I can't post an image, but it's tool #4 from the right in the picture in the "answer"-post below, the one with a tiny, red weight on it.

I hope it helps!

  • If this works I will give you a kiss. Apr 7, 2011 at 21:40
  • Yes, by changing the label weight ranking, the label now works! Thanks!
    – user3502
    Jun 28, 2011 at 20:56
  • @Dan A constructive way to thank someone is to upvote their reply: that signals future readers that the reply has merit.
    – whuber
    Jun 28, 2011 at 21:20

I had this problem also, no labels regardless of what I do. I deleted each layer I had one at a time until the labels popped back up. This let me know which layer was giving the problem. Next I went through the attribute table for it. Turns out I had a point at 0 Easting and 0 Northing which blew the whole scale off and would only show labels at a ridiculous scale. After deleting this point the labels returned.

SHORT ANSWER : check attribute tables for mistakes in LAT/LONG or Easting/Northing.

  • removing the rows with zero's in the x/y's fixed this for me. Thanks soo much for the tip, this was really annoying!
    – user33195
    Jul 4, 2014 at 16:25

As I edited into the initial question, the problem wasn't with the specific layer I was trying to label, but rather with trying to label ANY feature in the map.

Upon creating a new document and adding the same layers I was having trouble with, labels appeared just fine.

Marking this as answered as I think I've moved onto a different question than the one I asked initially.

  • 1
    This is a fairly common problem in ArcMap. You could have also tried running MXDoctor and defrag on the map document which often corrects such problems but not always. Starting over with a new mxd is usually a good second step in troubleshooting these issues. Aug 27, 2014 at 1:13

Based upon the fact that no labels are being displayed for any layers, one other setting you might want to look at is the "Pause Labels" button on the "Labeling" Toolbar.

If you (or someone else) has clicked it on, this will prevent all labels from being drawn for the entire map document. It is very easy to miss seeing whether or not the button is depressed or not. Typically this is used to help speed up rendering for the cartographic design, but the user doesn't want to turn on/off labeling for every layer.

enter image description here

  • Is this toggle actually saved as part of the MXD? I thought it resets every time a document is reopened.
    – nmpeterson
    Mar 4, 2013 at 16:56

I had this problem since v10 came out, and only now found how to fix it, but don't know if this is cause of all instances of labels not drawing, but in my case it was the cause: - when adding result of map algebra or geostat analyst result (e.g. Kriging solution), it causes map extent to show ### error when you click zoom to full extent (the globe icon) - when you delete the geostat analyst solution layer (after saving it and exporting to raster for example), or any offending layer which caused this problem, the labels immediately come back and labelling works after this - previously I had to start from scratch and setup new map; why geostat analyst would cause this I don't know; why map algebra would cause it, also don't know, but has to something to do with messing up scaling of project; it seems that when zooming to full extent works, the labelling also works...


I do agree the reason is a layer with one or many NIL (non existent) coordinates. For example a point layer event theme generated of a table (i.e. excel) which contains blank lines at the bottom of the table.

If You do not want to mess with the offending layer or table, You can always go to - Layers - Properties - Data Frame - and change the "Extent Used By Full Extent Command" from 'Extent of data in all layers (Default)' to 'Other' and specify one of Your own layers which has reasonable extent.

Click OK - labels are visible again.

Just do not forget to change it back to default settings if You do not need this any more.


I have had similar problems, some of which the feature weight fix above corrected. However with continuing problems of labels not being placed or in a rather random manner, I eventually found that the problem is related to the "Scale symbols when a reference scale is set" check box and the reference scale itself. Though I"m not sure what the root of the problem is, it seems that the scale symbol check box is having no effect and I eventually had to turn of the reference scale to get the affected layers' labels to show. So if you are continuing to have troubles check the references scale and associated layer check box. I hope this helps someone.


Also there is one solution that might help. I checked in the Data Frame properities what engine is used to label features in the data view. I changed the ESRI Standard label engine into ESRI Maplex label engine and it actually went out fine - all the labels went back.


I have found that the Data Driven option can also restrict labeling. Labels outside a data driven clipping limit will not display even thought the layer is checked as exempt. Just my 2cents.


I went to the same problem. After checking each layer's coordinate systems, I found out that the problem exists due to the difference in coordinate system. Just simply make sure the layer has the same coordinate with other layers, so the labels will be then displayed.


switching labelling engine did the trick for me... (see first post)

the below suggestions pretty much cover all of your first check things when labelling won't work. The only other thing I would do would be to switch your labelling engine (if it is maplex go to standard and vice versa). – badkins Mar 31 '11 at 12:50



IF you're using SHP files. Open the SHP file in Excel and see if the labels actually are there. You'll usually see the column names match up to the available label types

  • 2
    Isn't it easier to open the Attribute Table in ArcMap?
    – klewis
    Jun 28, 2011 at 22:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.