6

I created a QGIS map, which I was able to edit (right click on layer and select toggle edit, or use button in tool bar). Having returned to work on the plan, most layers now have this button greyed out. How can I work through to find what has caused this?

The affected layers are shapefiles - points and lines, based on KML files imported from Google Earth. I can still edit shapefiles created directly from within QGIS.

After importing I could edit then (e.g move points), and have subsequently added further layers (rasters and shape files) and grouped layers.

I do not know at what point I stopped being able to edit. I have tried editing them within and outwith groups.

The only solution is to save as, new file name, then add the new layer - but I loose properties such as line width. This is fine for now, but to prevent it happening again, I wonder what went wrong or a better way to fix?

I have used latest GIS (2.0.1-Dufour) from start of the project. Files are stored locally.

  • 3
    Please provide more detail about the layers contained in the map. What are the sources of these layers, meaning, what format are they stored in, eg. shapefile, PostGIS, ESRI Personal Geodatabase, etc. Where is the file stored, on a server or locally? What QGIS version, and have you changed versions between times of accessing this map? The more detail you can provide about your workflow and situation, the better the chances of someone being able to help you with your problem. – Get Spatial Dec 10 '13 at 0:51
  • Did you create a feature subset in your layer properties? I think this will grey out all edit buttons. – SAnderka Dec 10 '13 at 9:26
  • @GetSpatial, I have improved the question based on your comment. – Jo Pedder Dec 13 '13 at 10:27
  • @SAnderka I am not sure what a feature subset is - I have been back to look through the options in properties and cannot find a reference to this? Is there another term I could be looking for? Thanks – Jo Pedder Dec 13 '13 at 10:28
  • @Jo Pedder: You can choose to show just a subset of features defined by an expression. You can set this up in the layer properties, "General" tab --> "Feature Subset". Just click on "build query". But I guess this wasn't your problem, then. – SAnderka Dec 13 '13 at 10:48
6

Layers based on KML files are most likely to cause such problems. KML does not offer all possibilities we use in QGIS, and has other features we can not handle in QGIS. In such cases, editing of the layer will be abandonned by greying the button out.

Best practice is always to load a KML, save as shapefile (or spatialite database), delete the KML layer and work on with the shapefile(s).

For the styling, you can save the styling for every layer you created as .qml file, and reload it in another project.

0

Similar problem with me. In my case re-saving the kml into shp files did not work. But I noticed that I had another layer as Geopackage. When I saved this as shp all the layers became editable again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.