3

I want to shorten a feature (a polyline representing a road) in QGIS 2.0.

I tried the 'cut features'-tool that look like a pair of scissors. First I chose the right layer, and then clicked 'Toggle'. Then I selected the road and chose the cutting tool. But, when I selected it, my polyline "disappears"? I never got a chance to start cutting.

I don't remember having any problems with this in QGIS 1.8. Is there a step that I am missing here?

I really want to get this to work, without having to download QGIS 1.8 again.

  • Try doing it in a different project, just in case. – Alexandre Neto Dec 10 '13 at 10:49
  • @alexandre I just tried it in an other project, it didn't work there either. The selected part just disappeared there to. – SoS Dec 10 '13 at 10:57
8

The pair of scissors without a feature on the icon (red) are a tool that works on the selected features as a whole. That is, the tool cuts the selected features so you can paste them somewhere else (the same as copy-paste, just cutting instead of copying). What you are looking for is the "Split Features" tool (green) in the "Advanced Digitizing" toolbar.

Scissors tools

  • In that case I guess it did work... How do I activate the "Advanced.." toolbar? I can't see the Split features tool on my screen. – SoS Dec 10 '13 at 11:06
  • 1
    In "View" -> "Toolbars" or by right-clicking on the empty space next to a toolbar and activating it in the context menu. – Matthias Kuhn Dec 10 '13 at 11:10
1

In view -> toolbars click on "advanced digitizing" toolbar.

Then use the commands in that toolbars (see answer above). "Move feature" command is nevertheless in the toolbar above (third left to the scissors), not in the "advanced digitizing".

This is how I do it in 2.6.1. but I guess it is the same in 2.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.