4

I encounter recurrent problems with the geoalgorithms that perform interpolations. No matter what technique I use I end with the following errors. As stated in the OGR tab QGIS 2.0 is unable to open a file in C drive. I have very little IT background so the message error is meaningless.

Is there anybody able to decrypt the message and solve the problem?

enter image description here

enter image description here

here this is the algorithm i used

enter image description here

  • Try copying everything in the log screen just behind the window. From here I can already see "Error" just below GDAL, so it contains pointers as to where things go wrong. – johanvdw Dec 10 '13 at 20:49
  • I don't know I have understood properly but this is what I can read – ilaria marengo Dec 10 '13 at 20:58
  • SAGA execution console output C:\PROGRA~1\QGISDU~1\bin>set SAGA=C:\Program Files\QGIS Dufour\apps\saga C:\PROGRA~1\QGISDU~1\bin>set SAGA_MLB=C:\Program Files\QGIS Dufour\apps\saga\modules C:\PROGRA~1\QGISDU~1\bin>PATH=PATH;C:\Program Files\QGIS Dufour\apps\saga;C:\Program Files\QGIS Dufour\apps\saga\modules C:\PROGRA~1\QGISDU~1\bin>saga_cmd shapes_polygons "Polygon Centroids" -POLYGONS "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\tests\data\polygons.shp" -CENTROIDS "D:\Users\ilango13\AppData\Local\Temp\processing\a9fccaf022ae41298b805964ab7fe6b0\CENTROIDS.shp" – ilaria marengo Dec 10 '13 at 20:58
  • library path: C:\Program Files\QGIS Dufour\apps\saga\modules\shapes_polygons.dll library name: Shapes - Polygons module name : Polygon Centroids author : (c) 2003 by O.Conrad – ilaria marengo Dec 10 '13 at 20:59
  • Load shapes: C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\tests\data\polygons.shp... Parameters Polygons: polygons Centroids: Centroids Centroids for each part: no – ilaria marengo Dec 10 '13 at 20:59
3

You get this message whenever the SAGA process is stuck somewhere, and therefor the resulting file is not created. The message tells you also that SAGA is correctly installed, so it must have to do with the data, or the parameters you entered.

Usefull hints may come from the log, which is behind the error message box.

Just a guess: Are all your layers in the same CRS? That is, when switching On-the-fly reprojection off, are they still in the same place? This is mandatory for any SAGA algorithm that uses more than one layer.

  • Andre, in QGIS i loaded only one file so there wasn't a problem with CRS (the CRS is EPSG:4326 - WGS84). The "interesting" bit is that If I run SAGA from its gui.exe I manage to have a correct map. thus the algorithm works by sure and I am using correct parameters. For an unknown reason doesn't work in QGIS and gets stuck somewhere. It would be great to know where and why. thanks – ilaria marengo Dec 10 '13 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.