So far I cannot detect any difference between the two input feature classes other than that anything in pre 10.2 copy features will work. If I set the input to be a FC from a 10.2 file GDB, I get the 'ol 000210 error. Projections aren't an issue, both inputs reside in the same level of the file structure, no differences in OS permissions. I've created a fresh fGDB for testing, same behavior. I can even have both FC versions in the same MXD and just switching the input in the model decides success or failure.

To be fair, when i say non-10.2 GDB, my older ones are almost all 9.3. I'll try to test with an intermediate version as well. I have tested with different output locations and no problems there. Its odd because the error raised is related to output...not input. I am currently writing to %scratchFolder%

And to honor the Stack Exchange protocol, here is my question:

Has anyone seen similar if not identical behavior from this? Again, it appears to only affect 10.2 fGDB using the copy features tool. ExportDatatoZip

  • Have you tried Featureclass to Featureclass?
    – Aaron
    Dec 10, 2013 at 21:07
  • Can you give us a screenshot of your model? What processes come before "Copy Features"? Have you tried adding a "Make Feature Layer" tool immediately before the Copy Features tool? Dec 10, 2013 at 21:07
  • I've not tried FC to FC, but I do need a shape as my output. @RyanDalton I've added a screenshot with the process/tool circled. I'll gladly try make feature layer, but why would it work on a 9.3 fGDB and then not on a 10.2 fGDB? Dec 10, 2013 at 21:33
  • 1
    Tried adding an extra make feature layer too and still no luck. My gut it telling me this is a bug with the upgraded fGDB? Can anyone try a quick copy features to %scratchFolder% with model builder on an upgraded DB? Dec 10, 2013 at 22:06
  • 1
    @Aaron No & Yes! the syntax is correct and my understanding is that ESRI has suggested we move to either the scratchFolder or scratchGDB rather than workspace...at any rate, I did get the FC to FC to work, so thanks for that! I still suspect a bug for copy features at 10.2. I'd be glad to share another snapshot of the fixed model for posterity, but i'd have to answer my own question, and well...you're the one who came up with the fix! Dec 10, 2013 at 22:21

2 Answers 2


Two things to try here:

  1. Run Feature Class to Feature Class as a workaround
  2. %scratchFolder% will create a folder in your workspace and dump files into it. Make sure to define the scratch workspace and a variable (e.g. %scratchFolder%\temp). Otherwise, Arc will try and create a folder within the default geodatabase.gdb folder and shoot you an error.

From ESRI Help 10.2 Scratch Folder

  • 1
    I think specifying scratchfolder is independent of any environment setting...that's why we're supposed to use it over the workspace variable. Also, still my testing was quite thorough and I think a bug lies at the heart of this. The workaround is a savior, don't get me wrong and as usual Stack Exchange got me to success before ESRI support did. I have an incident open with them and will provide a NIM reference if my hunch is correct. Dec 11, 2013 at 0:40
  • 1
    I reread the tech article and I see your point. But even if I have a gdb in my scratch env variable and I use scratchFolder, it will write to that folder every time. It must be an order of operations thing. These comments about env settings should be considered independent of the issue with copy features. Many thanks Aaron. Dec 11, 2013 at 1:06

I came across this same issue and tried everything. Turns out the issue was that the layer name that I was giving the output started with a number and you cannot use the copy features tool to write to a fgdb if the layer name you are giving it starts with a number. There are other rules for how to name your output layer regarding this as well. It was a while back so I'm not sure of the source for that information. All I know is that it worked once I fixed my output name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.