1

I'm trying to install the qgis2kml plugin for qgis. Its not showing up in the Plugin Manager search and the only qgis "repositories" I can find are websites for downloading source code.

Which is fine, except for that I don't know how to install python source into qgis, and there doesn't appear to be a readme available in the plugin source code.

I could solve my problem, installing the qgis2kml plugin, in three different ways, based off what I've described so far: - by installing directly from the source code using some low level apis or some such thing - by finding a repository aside from the Official XML repository that has qgis2kml

OK so that's two. I'm wanting to export a heatmap from qgis that is colorizing over 50 different shapes in 9 different shades of a segmented continum from green to red. This would take so long to do I simply wouldn't do it and it would be amazing to export heatmaps as translucent kml overlays as I know can be done in kml.

1

there is a plugin called MMQGIS that works with QGis 2.0.1-Dufour & can export to kml, complete with a decent stylesheet rendering. It has a bunch of other features and this is just one of them.

0

qgis2kml is no longer in the QGIS 2.0 Plugins Manager because there were several significant API changes between 1.8 and 2.0 releases. After downloading and installing the plugin manually, then editing its base QGIS version requirement to 2.0 (to get it to install), I noticed the plugin fails work.

This means the plugin needs updated to work with the 2.0 API. From the plugin's page, go to the developers source code management site and file an issue with them to upgrade their plugin.

If you get no response after a while, you can post to QGIS developers list and see if someone is interested in working with the code to update it and send the original developer a pull request.

Note, you can install plugins manually as well, though most QGIS 2.0-compatible plugins are already in the official repository.

0

qgis2kml was developed for QGIS 1.x.

You can still find Windows installers for that on this page.

You should first make a test if your current Qgis project file can be opened with that version. If that fails, save your styling as .qml file , and load that into a newly created QGIS 1.x project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.