1

I have been trying without success to install the LeCos plug in on QGIS2.0 on my Mac. I originally tried it on QGIS1.8 but was unable to install the dependent packages (PIL,scipy and numpy). I updated to QGIS 2.20 and successfully installed the packages, however I am still unable to install LeCos. THis is the message that comes up:

enter image description here

The packages are definitely installed because I checked by doing this in python: enter image description here

Has anyone else installed it successfully?

4
  • You probably the one who commented on my blog. Your error is most likely related to wrong packaging and you need to contact the distributor. _ni_support.py is normally included in the scipy python base (tinyurl.com/pco2489), but apparently it was not successfully packaged into the kyngchaos sources
    – Curlew
    Dec 11, 2013 at 23:58
  • Yes that's me! Ok great thanks a lot for that info will give it a go and report back.
    – Pop
    Dec 12, 2013 at 2:23
  • I thought downloading the packages from other sources might fix the problem. Unfortunately it hasn't.
    – Pop
    Dec 12, 2013 at 3:18
  • Alternatively you could try to open a QGIS python shell and install scipy via pip. (gis.stackexchange.com/questions/54674/…). Nathan also posted a guide for Win on his blog -> tinyurl.com/qcdq7fh Don't know if this will work on MAC though...
    – Curlew
    Dec 12, 2013 at 15:17

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.