1

Good day to all,

Am getting the following error when running utils/setup.php in nominatim 2.1:

Reading in file: /storage/Library/geodata/africa-latest.osm.pbf

Processing: Node(54854k 62.1k/s) Way(4740k 8.26k/s) Relation(0 0.00/s)get_way_list failed: (7)

Arguments were: {48725024,162617539,160913750,95107659,95107632,95061927,94828942,94795314,94795281,48725023,48724896,48493347,48491792,48457398,23462217,23463574,23463575,23463577,23556792,23556834,23496195,48501117,48501200,48501201,48501202,48501381,48501375,48501379,48501377,48457182,48457183,48457186,48457403,48457198,48457202,48457177,48491809,48491797,48493349,48493348,48493350,161906130,161906134,93072207,93086913,93086923,93086924,93086919,93062967,162596086,162596088,94795372,162596089,94795354,94795273,94795305,94795303,94795351,94795355,94795375,94795358,94795370,94795380,94795278,94795381,94795250,94795368,94795378,94795307,94828944,94828939,94828937,94828935,94828940,94828948,94828941,94828951,94828938,94828936,94828949,94828934,94828950,94828952,94828947,95061929,94828946,95061931,95061930,95061926,95061928,95099314,95099312,95099311,95099313,95085072,95085071,95085075,95085076,95085070,95085074,162596087}, 
Error occurred, cleaning up
ERROR: Error executing external command: /storage/Nominatim/osm2pgsql/osm2pgsql -lsc -O     gazetteer --hstore -C 958 -P 9999 -d nominatimnew /storage/Library/geodata/africa-latest.osm.pbf
Error executing external command: /storage/Nominatim/osm2pgsql/osm2pgsql -lsc -O gazetteer --hstore -C 958 -P 9999 -d nominatimnew /storage/Library/geodata/africa-latest.osm.pbf

The command I'm running to do the initial import to create a new Nominatim DB is:

./utils/setup.php --osm-file africa-latest.osm.pbf --all

within the Nominatim directory.

Running osm2pgsql 0.85.0, PostgreSQL 9.3.2, PostGis 2.1.0 running on Slackware 14.1 64 Bit.

Thanks.

  • Please add the versions of osm2pgsql, Postgresql and Postgis you are using; as well as the operating system. – AndreJ Dec 13 '13 at 8:26
  • Hi. osm2pgsql 0.85.0, PostgreSQL 9.3.2, PostGis 2.1.0 running on Slackware 14.1 64 Bit. Thanks – Fabrizio Mazzoni Dec 13 '13 at 8:29
  • It often works better if you can add the information into the question, which is easy to do if you just click edit below the question. – BradHards Dec 13 '13 at 10:21
0

I have the same problem. It is the problem with OSM data.

First of all, you can download old osm.pbf file and verify that everything is OK.

In my case, I use old version of libgeos lib.

sudo dpkg -i libc6_2.17-93ubuntu4_amd64.deb
sudo dpkg -i libgeos-3.3.3_3.3.3-1.1_amd64.deb
sudo dpkg -i libgeos-c1_3.3.3-1.1_amd64.deb
sudo dpkg -i libgeos-dev_3.3.3-1.1_amd64.deb

sudo dpkg -i libc-dev-bin_2.17-93ubuntu4_amd64.deb
sudo dpkg -i libc6-dev_2.17-93ubuntu4_amd64.deb
sudo dpkg -i libnih1_1.0.3-4ubuntu16_amd64.deb
sudo dpkg -i libnih-dbus1_1.0.3-4ubuntu16_amd64.deb

sudo apt-get autoremove

sudo dpkg -i libgeos-3.3.3_3.3.3-1.1ubuntu1_amd64.deb
sudo dpkg -i libgeos++-dev_3.3.3-1.1ubuntu1_amd64.deb

cd ~/src/osm2pgsql
./autogen.sh
./configure
make
  • Ok. So the suggestion is to use an older version? – Fabrizio Mazzoni Feb 14 '14 at 7:15
  • use older version (you can verify that the problem is the OSM data). And then install the latest version of software or use old data. – AmShegar Feb 14 '14 at 7:18
2

I know this is an old answer, but as it came up in my Google results it might do the same for others.

Unfortunately, the Nominatim install doesn't provide a clear error message, despite it being available. Thus, the answer could be anything.

In my case it turned out the hard disk which hosted the database had run full, so the import aborted.

When you're debugging, try running the command which Nominatim indicates has failed (in the asker's case, /storage/Nominatim/osm2pgsql/osm2pgsql -lsc -O gazetteer --hstore -C 958 -P 9999 -d nominatimnew /storage/Library/geodata/africa-latest.osm.pbf) manually to track down the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.