1

I'm getting a strange result when I'm generating an hillshade with the gdaldem hillshade command.

Here is my command (see the compute_edges parameter):

    /Library/Frameworks/GDAL.framework/Versions/1.10/Programs/gdaldem hillshade -compute_edges -alt 90 -z 8 -s 111120 /Users/jflegendre/Documents/GDAL_PROJECTS/MP/01-DEM_MERGED/out.tiff /Users/jflegendre/Documents/GDAL_PROJECTS/MP/02-HILLSHADED_DEM/hillshaded_dem.tiff

Here is a section of the output raster:

enter image description here

I've also tried to clip the result with a perimeter shapefile, but there still had some black pixels.

I've tried too the nearblack gdal command without effect. The image that you can see in this post is the result of the nearblack command. So I'm stuck actually.

Can someone help me on this?

Regards

  • What is the no data value of your output image? – user10353 Dec 16 '13 at 19:35
  • The no data value is 0. – Geo Karta Dec 16 '13 at 20:30
  • It's probably a display issue. Try to change your no data value (in qgis, or using gdal_edit.py) to an out of range value. – user10353 Dec 16 '13 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.