0

I am working on GeoServer Version 2.4.2 . I have one layer 'beat' in PostgreSQL database. I have publish layer in geoserver but its not opening OpenLayers layer preview link. It gives error as

Internal error occurred java.io.IOException null ERROR: Operation on two geometries with different SRIDs  

I have checked all previous question but i didn't understand how to resolve this. I try exporting the layer and it export successfully in shp and render in QGis. Also it export in geojson succesfully so why its not rendering in layer preview i am confused. I tried following queries but it shows proper results as

select * from geometry_columns where f_table_name = 'beat';
    f_table_catalog  f_table_schema  f_table_name  f_geometry_column  coord_dimension  srid   type          
    ---------------  --------------  ------------  -----------------  ---------------  -----  ------------  
                     nmmccommon      beat          the_geom           2                32643  MULTIPOLYGON 

select distinct(st_srid(the_geom)) from beat;
st_srid  
-------  
32463    

Distinct srid is also single then at what point Operation on two geometries with different SRIDs error occure. Geosever can export it shp also successfully render in QGis. I know its repitative question but i didn't found a useful solution which suits in my case.

1

I solved the problem by setting srid again to beat table.

UPDATE beat SET the_geom = ST_SetSRID(the_geom,32643);

after that layer render successfully . Actually i don't understand the problem but in my case i am sure about the projection so i reassign the srid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.