I have been trying to install QGIS on Mavericks and I have failed. Prior to installing QGIS, I installed GDAL using homebrew. I also installed Numpy, SciPy and pyqt using the detailed instructions provided at: http://www.thisisthegreenroom.com/2011/installing-python-numpy-scipy-matplotlib-and-ipython-on-lion/

I modified my .bash_profile so that when I run echo $PYTHONPATH

I get /usr/local/lib/python2.7/site-packages:

I tried first installing qgis running

brew install qgis --with-grass --with-postgis

and I get the error message

libtool: link: cannot determine absolute directory name of `@@HOMEBREW_CELLAR@@/libpng/1.5.17/lib'
make[3]: *** [libcairo.la] Error 1
make[2]: *** [install] Error 2
make[1]: *** [install-recursive] Error 1
make: *** [install] Error 2

READ THIS: https://github.com/Homebrew/homebrew/wiki/troubleshooting

These open issues may also help:

Then I also tried downloading the QGIS .dmg file from http://www.kyngchaos.com/software/qgis However, I get an error message each time I try opening Install QGIS.pkg saying that I need matplotlib that I already have!

Is anyone else also having problems installing QGIS on Mavericks? Does anyone know how to solve it?

  • Hello, to me its seems that QGIS isn't ready yet for Maverick. I only see installer for Snow Leopard and Mountain Lion at kyngchaos. On the main page he says: "I don't plan on upgrading to OS X Mavericks (10.9) soon". regards
    – Jörn
    Commented Dec 18, 2013 at 13:01
  • Wrong, read the text: "that my Lion builds work on Mavericks". No problem for me
    – gene
    Commented Dec 18, 2013 at 13:13

1 Answer 1


You are trying to mix different things:

1) You want to use the Homebrew version of QGIS:
  • Everything must be installed by Homebrew as binaries and libraries in /usr/local/Cellar with symbolic links in /usr/local/bin, GDAL/OGR, QGIS, ....

  • the Homebrew QGIS version uses the Homebrew Python version with modules in /usr/local/lib/python2.7/site-packages

  • All the Python modules you have installed (Numpy, SciPy pyqt...), works only with the Homebrew version of Python

  • If it doesn't work, it is the problem of Homebrew (can find libpng library, for example)

2) you want to use the Kyngchaos's version of QGIS
  • You should install his versions of the libraries ( Unix Compatibility Frameworks (KyngChaos) ) which are installed as Frameworks in /Library/Frameworks).
  • The QGIS version uses the Apple Python with modules in /Library/Python/2.7/site-packages
  • If you don't know Python you can download the Python modules at Python Modules (KyngChaos)
  • the installer examine whether there is a folder named "matplotlib" in /Library/Python/2.7/site-packages. If not, no installation (even if matplotlib is installed in /usr/local/lib/python2.7/site-packages)
3) if you want, you can also use the MacPorts version of QGIS
  • with the Python version of MacPorts (in /opt), and so on.
4) conclusions

So you have to choose between 2 solutions (Homebrew and Kyngchaos) without mixing them ( unless you know UNIX path manipulation very, very well ).

And the people using the Kyngchaos version do not experience any problem.

  • Thank you for your answer, I installed all the libraries and Python modules with Kingchaos to then install QGIS from Kingchaos and it worked. Since I have tried all the previous steps with Homebrew, I guess there is a problem with the brew version of QGIS. Thank you for your explanations
    – Doon_Bogan
    Commented Dec 18, 2013 at 15:15
  • Of note: see gis.stackexchange.com/a/99841/6725 for a currently important fix needed for the GDAL.framework Python setup. On fresh installs, this affects things like Processing plugin.
    – dakcarto
    Commented Jun 10, 2014 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.