5

We have file geodatabase on a network drive, version 9.2, which locks every time a specific machine starts up ArcMap 10.0 or ArcCatalog 10.0. This machine isn't actually reading anything from this geodatabase. It is just opening up a blank map document or browsing other directories elsewhere on the network. However, this machine has accessed this geodatabase in the past. Has anybody ever come across this?

Things we have tried so far to stop this locking:

1 - Opened up enough map documents so that none of the mxd's in the recently opened list in the "File" menu in ArcMap have data from this database.

2 - Disconnected this network drive from the folder connections in ArcCatalog

3 - Deleted the normal templates for ArcCatalog and ArcMap.

4 - Re-started the machine

5 - Deleted the original database and made a new one in the same location.

None of the above worked.

The only thing that works is to remove the connection from this machine to the network share i.e. remove the connection to the "N" drive in MyComputer. Unfortunately this isn't a feasible solution as the machine needs to have that network share mapped to that drive letter.

Any suggestions on how to prevent the lock?

  • Not directly related, but could be useful to review a recent bug for file geodatabases after installing some Windows updates: support.esri.com/zh-cn/knowledgebase/techarticles/detail/41119. Another thing: would you consider an option to create a new file geodatabase and just move the data into a new one? Then just delete the source one and rename the new to match the previously deleted. – Alex Tereshenkov Dec 18 '13 at 14:46
  • 1
    Did you rename ArcCatalog.gx or if that doesn't work more broadly reset the entire application profile (forums.arcgis.com/threads/…)? – johns Dec 18 '13 at 15:31
  • 1
    When you do step 5, do you give it the same name? If not try calling it something else to see what happens? – Hornbydd Dec 18 '13 at 15:40
  • 2
    the machine could have that db set as it's default db/workspace. another possibility is that the search index has been set to that location. – Brad Nesom Dec 18 '13 at 17:30
  • 1
    I don't know your database but, if there are any toolboxes or geo-locators/geocoders in that database, you will want to be sure those aren't registered as defaults or such as that as it would likely access those locations every time starting up either application. Just a thought if it's relevant to your situation. – John Dec 18 '13 at 23:08
1

@Dan_h_b.

Rename ArcCatalog.gx or if that doesn't work more broadly reset the entire application profile (http://forums.arcgis.com/threads/90079-Resetting-your-ArcGIS-application-profile). ESRI tech support always suggests resetting the application profile. It can be rough on customizations but if it works you can sometimes go back and one by one replace templates and/or registry sections to find the problem more narrowly.

3

Viewing the contents of a file geodatabase OR editing its contents using an Esri product, it doesn't matter which, will produce a .LOCK file inside the file GDB's folder on the file system which can be seen via Windows Explorer. It will contain some numbers in its filename, one of which refers to the process ID (PID) of the active process connecting to it. To know which process or application has your FGDB locked, open Task Manager and explore the contents of your GDB folder on the file system using Windows Explorer. Add the PID field to Task Manager and then compare the process IDs in Task Manager to that of the lock file to identify the culprit. The presence of the .LOCK file is essentially an exclusive lock and won't allow you to do much else other than view the FGDB contents until it is gone. Killing those connections can be done by ending the process brutally in Task Manager or gracefully closing an application or stopping a GIS service, if applicable.

Now, if there is no lock file or process holding on to the FGDB, then you probably have a system lock of some sort that hasn't cleared up. Rebooting should resolve that; but if rebooting isn't possible then you'll need to close the FGDB files manually. If you have Windows 7 or Server 2008 R2 or higher, read on:

If you are still having issues with deleting a geodatabase on the file system despite the fact that the .lock files no longer exist, it's possible there is still a process lock on one or more of the files within it. That being said, if you're using Windows Server 2008 / Windows 7 or later you can try one of the following methods:

From the Start menu, type FSMGMT.MSC, then multi-select the files you want from the GUI, then right click them and chose "Close". That method should force close the files that are technically still open due to a process lock.

or

From a batch file, run the following (example is for a file geodatabase) to close a file named a00000225.gdbtable (this filename is just an example):

cd C:\this_server\directory\subdirectory
for /f "skip=4 tokens=1,2*" %%a in ('net files') do if %%b == C:\this_server...\a00000225.gdbtable net file %%a /close

You can modify the command above to loop through all of the files in the file geodatabase to close them all rather than specify them individually, which would be tedious since there are so many.

From the command prompt, type NET FILES to see what the bold text above should contain.

Remember that double percent characters are required for batch files (in other words, %% rather than %) but single percent characters are used when running the command outside of a batch script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.