3

I have installed the OpenGeo Suite community edition, version 3, onto Windows 7 multiple times in the past, with virtually no problems. With the latest version of OpenGeo Suite (4.0.1) (which includes PostGIS 2.1), I am able to install almost all of the components successfully, except PostGIS. With earlier editions, PostGIS was installed as part of the full Opengeo installation process, but now, although PostGreSQL 9.3 is successfully installed, there are no PostGIS or opengeo database templates installed, nor are the spatial functions installed. Nevertheless PostGIS 2.1 is installed.

It seems that OpenGeo Suite 4 intalls all the component but no longer creates a default database or user account in Postgresql/PostGIS.

What steps are necessary to configure OpenGeosuite (windows installation) in order to be able to fix this issue? thanks

3

What you are running into is that PostGIS has changed the way it is installed. It is now installed as a simple extension to PostgreSQL, in whichever database you choose. This means that there is no longer a template database created.

Here is the help documentation on Creating a spatial database using Extensions.

The new steps to create a spatially enabled database are:

  1. Create a new database: createdb [yourdatabase]
  2. Install the PostGIS extension: CREATE EXTENSION postgis;

Further, you now install the Tiger Geocoder using an extension as well: Tiger Geocoder Enabling your PostGIS database: Using Extension

Here is a screenshot of a PostgreSQL database that I have created, with the PostGIS and geocoding extensions installed. Postgresql with spatial extension

To be clear, the Opengeo Suite 4 contains everything you need to create a spatial database. You've already installed the correct components. The configuration step is not with the Opengeo Suite, but as a simple enabling process in PostgreSQL itself.

On that note, it would be useful for the Boundlessgeo people to add this particularly pertinent change into their release notes for the software.

  • Glad I could help. As a means of helping others who are searching for a similar problem, please mark this answer as accepted. Thanks! – Get Spatial Dec 20 '13 at 7:51
  • I have the same problem. I input in psql console: psql -d [yourdatabase] -c "CREATE EXTENSION postgis;" (my example: psql -d testgis -c "CREATE EXTENSION postgis;"). But nothing happens then... – tobias47n9e Dec 20 '13 at 21:28
  • Reinstalling everything with 32 bit versions helped ;) – tobias47n9e Dec 21 '13 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.