For an ArcGIS project opened in ArcMap 10, we have added polygon layers representing different geographical features.

After all the polygons were created, we opened the attribute tables for those layers, and to our shock/dismay, the cells in the "shape_area" column all showed zero! (The "shape_length" field was correctly filled.) We also tried the Measure tool in the toolbar, but it could only measure distances, and the Area button was greyed out.

We checked to make sure that all layers were in the correct geographical coordinate system (WGS 1984).

What did we do wrong? Is there any way to obtain the areas of the polygons we created?


As Brad suggested, I tried to right click on the "SHAPE_Area" column (both on the column label and in the column), but the "Calculate geometry" (and "Field calculator") options were also greyed out.

  • 2
    How were your features created? Have you tried running repair geometry against your feature class? – Derek Swingley Apr 4 '11 at 20:26
  • @Swingley: Thanks for the tip. I just tried both Check and Repair Geometry against the feature class in question. The problem remains..... – hpy Apr 4 '11 at 20:42
  • 4
    When the areas are all zero usually one (or both) of two things has occurred: no area has been calculated or else the shapes are relatively small (such as parcels) and areas are computed in squared decimal degrees. (One square kilometer is less than 0.000001 squared DD.) The latter arises from not using a projected coordinate system. – whuber Apr 4 '11 at 21:07
up vote 7 down vote accepted

Are you definitely working with a projected shapefile? If the shapefile is in ArcMap, right-click on the shapefile, click on Source and look to see that is in a Projected Coordinate System rather than a Geographic Coordinate System


If it's geographic, go to Data Management Tools ->Projections and Transformations -> Feature -> Project. Then add the shapefile you want to project, and choose your output coordinate system. If you have any other file for this project that is projected, navigate to that file for the Output Coordinate System or choose one from the default appropriate to your location (e.g. by US state, or country).

Then try running the calculate polygons again on the projected shapefile.

right click on the area column and hit calculate geometry. select the correct unit. and the area.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Just tried to right click on the "SHAPE_Area" column (both on the column label and in the column), but the "Calculate geometry" (and "Field calculator") options were also greyed out! Any other ideas? Thanks. – hpy Apr 4 '11 at 20:11
  • 1
    Add a new field to your shapefile, then calculate geometry. Or import shapefile into a geodatabase. This way Shape_Area will be calculated dynamically. – Jakub Sisak GeoGraphics Apr 4 '11 at 20:52
  • 1
    @penyuan SHAPE_Area is one of the fields maintained by ArcMap, and is rarely in a desired unit of measurement. As Jakub said, add a new field before calculating geometry, and be sure that you are in a Projected Coordinate System (WGS 1984 isn't one!) like celenius said. – Nathanus Apr 4 '11 at 21:10
  • 1
    if it is a gdb you have to turn on editing before calculating a field value. – Brad Nesom Apr 4 '11 at 22:01

I solved this problem by choosing long integer when adding the new field, then calculating geometry.

  • I can't see any new field mentioned in the original question, so I'm not sure how this can be a relevant answer. Please add further detail – nmtoken Jul 12 at 10:42

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.