4

Using ArcGIS 10.2, I have an Excel file (Please review attached zipped Excel file) from which I am able to Generate Points by using the "Add XY Data". The points are generated on the map (using WGS84). I am then able to to export the points to Shapefile from Data --Export Data and then Add the new generated shapefile into the current document.

After this the problem starts:

  1. I can not Select Any Point data from graphic Selection By Location, Clicks on table or Selection by Attributes and ArcMap crashes after any type of Selection happens.
  2. After closing the map I am not able to add the new generated point shapefile into any map! It take several minutes and finally ArcMap display this error!

enter image description here

Can you please help me to fix this issue! I went all through to fix it but didn't work!

Download the Excel File

4

It works with 10.1, so it's looks like a bug of 10.2.

If you are in this situation:

ArcMap crashes when an XY event layer is in the data frame and the Get Point Features dialog box is opened from the Find Route tool

you appear to be encountering bug NIM094607 which is due to be fixed at ArcGIS 10.2.1.

enter image description here

Maybe you could try to export your data in a geodatabase instead of a shapefile.

UPDATE : for direct export to geodatabase, when you right-click on the layer, Data > export data, you can click to change the output feature class. There, there is an option of "save as type" where you can select "file and personnal geodatabase feature class".

By the way, you can also use "Make XY event Layer" from the geoprocessing toolbox "data management > layers and table views".

  • Thanks Rado, I tried to import /Export the shapefile into any geodatabase in both ArcMap and Arccatalog but system crashed again. Is there any direct way to generate them in geodatabase? – user1106951 Dec 29 '13 at 23:36
  • I have ArcGIS 10.2 installed and I was able to map the test.xls and export to Shapefile and fGDB FC. I see all 16 points and 97 fields. I find this registry key helps map xls & csv data. HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Microsoft\Jet\4.0\Engines\Excel: TypeGuessRows = 0 means scan everything. – klewis Dec 30 '13 at 20:24
  • @user1106951 could you make sure that you can reproduce your problem with the sample data that you've sent to us. Maybe one of your coordinates is completely out of bounds and this may cause ArcGIS to crash. – radouxju Dec 30 '13 at 20:59
2

Not seen that before and google isn't finding anything obvious. Possible workarounds:

  1. Re-save the Excel file into a CSV file and then go through the process again.
  2. Try using the QGIS importer - Import from Delimited file. That'll get you a shapefile you can then load into ArcGIS.
  3. Try a shapefile repair tool - http://arcscripts.esri.com/details.asp?dbid=13733
  • Thanks Jonathan, I already tried CSV but same thing happen again and that's why I was thinking may be there is something wrong with data structure/schema I didn't yet check the tool you suggested since asking for .Net Farmework 1.1.4322 and i am looking for it! – user1106951 Dec 29 '13 at 23:44
  • Yeah same thing happen with the tool for shapefile repair! Stops working! – user1106951 Dec 29 '13 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.