4

I am new to Ubuntu SAUCY and I must confess the transition from Windows has not been really easy for me. On Windows everything seems pretty much straight forward but I am getting frustrated because It seems when I try to install either pyproj, GDAL, Mapnik, proj4, PostgreSQL/PostGIS and other Web GIS packages they probably don't work together and their dependencies aren't the same.

My question is isn't there an easy way to get all these packages to work together?

When I install QGIS it removes something else same goes to Mapnik.

I install Mapnik the other day it even crashed and messed up my system, had to do a clean OS install all over again.

Here's the error I'm getting now:

libmapnik-dev: Depends: libmapnik (= 2.2.0-ubuntu1~saucy1) but 2.2.0-ubuntu1~saucy1 is to be installed
               Depends: mapnik-utils (= 2.2.0-ubuntu1~saucy1) but 2.2.0-ubuntu1~saucy1 is to be installed
               Depends: libpng-dev but it is a virtual package
               Depends: libtiff-dev but it is a virtual package
               Depends: libltdl7-dev but it is a virtual package
               Depends: libicu-dev (>= 4.2) but 4.8.1.1-12ubuntu2 is to be installed

Here is the last link(help) have have used. https://github.com/mapnik/mapnik/wiki/UbuntuInstallation

All the GIS packages I have tried installing are throwing this same error message.

I really need help on how to go about getting these installed because I can't work without all of them.

  • 3
    if you have the option to reinstall the OS , install the preconfigured FOSS4G live CD wiki.osgeo.org/wiki/Live_GIS_Disc_Quick_Start – geogeek Dec 30 '13 at 11:17
  • You could also install from source. – BradHards Dec 31 '13 at 2:52
  • I have reinstalled the OS again before I got this message and I've got a lot of my projects and apps back on the system. I will try it as a virtual add-on if it works – Anthony Dec 31 '13 at 12:17
  • 1
    @geogeek Please consider posting your comment as an answer so we have something to upvote. – underdark Feb 20 '15 at 13:22
3

In my experience using Ubuntu with GIS products will not be problematic. But you should try to keep to Long Term Support (LTS) versions of Ubuntu. The reasons are among others:

  • Cutting edge versions of Ubuntu tend to have fewer compiled versions of GIS-software (both desktop and server)
  • LTS releases are designed to be stable platforms that you can stick with for a long time. If you spend some time setting up a functional Ubuntu GIS-setup, then trying to keep up to date with the newest versions of Ubuntu is counter productive.
  • Upgrading to a newer version of Ubuntu might break your GIS setup. Dependencies in libraries might break.
  • Updates will be available for longer
  • ..and if it works - don't touch it.
1

If you have the option to reinstall the OS , install the preconfigured FOSS4G live CD

1

You can use the OpenGeo Suite to get a bunch of GIS stuff installed.

See instructions here: http://suite.opengeo.org/4.1/installation/ubuntu/install.html

That'll get you PostGIS, GeoServer, QGIS and GDAL.

As @narenarya says, sudo apt-get install python-mapnik2 should just work. It's important to use Ubuntu propertly and use package management. Another thing to try is using Ubuntu's PPAs. UbuntuGIS is reputable, so add that and use their packaging. If you do, though, be careful with mixing with Boundless' OpenGeo Suite repository as they package things up differently...

0

Just use the following command:

$ sudo apt-get install python-mapnik2

It straight forward installs mapnik2 on your Ubuntu system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.