I have used the technique as outlined in How to add complex Emergency Symbology (TrueType fonts) to QGIS? but have run into some difficulty.

I have used this technique for a map of water assets that I have created and it worked well. I created 16 different markers, so I saved them as a style for future use. Now I've had to go back, make a change to my map and reprint. I only get one symbol on my map. The full range of created symbols shows in my Layers List. I have tried to reload the saved style, I even went into each one and recreated it, then saved the layer again. The funny thing is that I have created the same styles for raw water as well. It is fine. I'm only having trouble with the potable water layer. Does anyone have any idea of what might be happening and how I might be able to fix it?

The first image is from my Layers window and shows what the items should look like. The second shows the closed boundary valves, and also the locations that should have other symbols. Font markers

Where items should be

Text of QML file:

"/> 0 0 0 Asset_Name 0 . . generatedlayout

  • Can you post some images?
    – Nathan W
    Jan 1 '14 at 23:34
  • Strange. Could you upload your style (qml) file.
    – Nathan W
    Jan 2 '14 at 0:11
  • What does that layer show for the "feature count"? Right click the layer in the TOC and select Show Feature Count. Hopefully they all have a value of >= 1 and none are 0.
    – SaultDon
    Jan 2 '14 at 1:35
  • You're right, SaultDon, the feature count for those items NOT showing is 0 and now that I look at the attribute table, I only have those closed Valves in my table. That's not something that I expected at all. Somehow, my table has become corrupted.
    – Johanna
    Jan 2 '14 at 1:41
  • I would try to add that layer again and check to see if it's attrib. table is still corrupted... If not, copy and paste the style from the corrupted layer to the newly added layer. You can copy and paste styles from the right-click menu of any layer. I wonder if that works? Trying in a blank qgs project could help. Or check the query for syntax issues on the corrupted layer.
    – SaultDon
    Jan 2 '14 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.