11

I installed QGIS (2.0.1-Dufour Dufour, d94c044) using both the stand alone installer and the OSgeo4w installer and seem to have an issue with the processing plugin. At first I thought that there was a python path issue, but now I am wondering if everything installed correctly. I don't know where the libraries live, so I would like some help debuging this issue.

Here is what I know:

  1. I get the error message below when I start up QGIS
  2. The following folders do not exist on my computer:
    • C:\Users\gstein/.qgis2/python
    • C:\Users\gstein/.qgis2/python/plugins
    • C:\PROGRA~1\QGISDU~1\bin\python27.zip
    • C:\PROGRA~1\QGISDU~1\apps\Python27\lib\plat-win
    • C:\PROGRA~1\QGISDU~1\apps\Python27\lib\lib-tk

Any thoughts about what may be wrong?

Error Message

Couldn't load plugin 'processing' from ['C:/PROGRA~1/QGISDU~1/apps/qgis/./python', 'C:\Users\gstein/.qgis2/python', 'C:\Users\gstein/.qgis2/python/plugins', 'C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins', 'C:\Python27\ArcGIS10.1\Lib\site-packages\pip-1.2.1-py2.7.egg', 'C:\Python27\ArcGIS10.1\Lib\site-packages', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\bin', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\arcpy', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\ArcToolbox\Scripts', 'C:\Python27\ArcGIS10.1\Lib\site-packages\win32', 'C:\Python27\ArcGIS10.1\Lib\site-packages\win32\lib', 'C:\Python27\ArcGIS10.1\Lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGISDU~1\bin\python27.zip', 'C:\PROGRA~1\QGISDU~1\apps\Python27\DLLs', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\plat-win', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\lib-tk', 'C:\PROGRA~1\QGISDU~1\bin', 'C:\PROGRA~1\QGISDU~1\apps\Python27', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\PIL', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\six-1.3.0-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\xlrd-0.9.2-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\xlwt-0.7.5-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\qgis\python\plugins\fTools\tools']

Traceback (most recent call last): File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 182, in loadPlugin import(packageName) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing__init__.py", line 20, in from processing.tools.general import runalg, runandload, alghelp, alglist, algoptions, load, extent, getobject File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\tools\general.py", line 29, in from processing.core.Processing import Processing File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\core\Processing.py", line 43, in from processing.algs.QGISAlgorithmProvider import QGISAlgorithmProvider File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\algs\QGISAlgorithmProvider.py", line 86, in from processing.algs.CreateConstantRaster import CreateConstantRaster File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\algs\CreateConstantRaster.py", line 1, in from processing.core.RasterWriter import RasterWriter File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins\processing\core\RasterWriter.py", line 28, in import numpy File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Python27\ArcGIS10.1\Lib\site-packages\numpy__init__.py", line 137, in import add_newdocs File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Python27\ArcGIS10.1\Lib\site-packages\numpy\add_newdocs.py", line 9, in from numpy.lib import add_newdoc File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Python27\ArcGIS10.1\Lib\site-packages\numpy\lib__init__.py", line 4, in from type_check import * File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Python27\ArcGIS10.1\Lib\site-packages\numpy\lib\type_check.py", line 8, in import numpy.core.numeric as _nx File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Python27\ArcGIS10.1\Lib\site-packages\numpy\core__init__.py", line 5, in import multiarray File "C:/PROGRA~1/QGISDU~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: DLL load failed: %1 is not a valid Win32 application.

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version: 2.0.1-Dufour Dufour, d94c044

Python path: ['C:/PROGRA~1/QGISDU~1/apps/qgis/./python', 'C:\Users\gstein/.qgis2/python', 'C:\Users\gstein/.qgis2/python/plugins', 'C:/PROGRA~1/QGISDU~1/apps/qgis/./python/plugins', 'C:\Python27\ArcGIS10.1\Lib\site-packages\pip-1.2.1-py2.7.egg', 'C:\Python27\ArcGIS10.1\Lib\site-packages', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\bin', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\arcpy', 'C:\Program Files (x86)\ArcGIS\Desktop10.1\ArcToolbox\Scripts', 'C:\Python27\ArcGIS10.1\Lib\site-packages\win32', 'C:\Python27\ArcGIS10.1\Lib\site-packages\win32\lib', 'C:\Python27\ArcGIS10.1\Lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGISDU~1\bin\python27.zip', 'C:\PROGRA~1\QGISDU~1\apps\Python27\DLLs', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\plat-win', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\lib-tk', 'C:\PROGRA~1\QGISDU~1\bin', 'C:\PROGRA~1\QGISDU~1\apps\Python27', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\PIL', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\six-1.3.0-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\xlrd-0.9.2-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\Python27\lib\site-packages\xlwt-0.7.5-py2.7.egg', 'C:\PROGRA~1\QGISDU~1\apps\qgis\python\plugins\fTools\tools']

3

It looks like you have Python27 twice in your path, once in QGIS and one in root, maybe installed by ARCGIS. This might raise problems.

I did not get happy with the QGIS 64bit builds, and am now working with the 32bit standalone build (on Windows 7 64bit). I did not update the plugin from the standalone version. Maybe that solves your problem too.

The processing plugin files are located under .qgis2/processing, not .qgis2/python/plugins as it was in QGIS 1.8.0.

0

I think this is an issue with the latest version of the processing plugin.

I went to upgrade my own processing plugin in the 64bit version and received a similar error:

Couldn't load plugin 'processing' from ['C:/OSGEO4~1/apps/qgis/./python/plugins\processing', 'C:/OSGEO4~1/apps/qgis/./python', 'C:\Users\heikki.vesanto/.qgis2/python', 'C:\Users\heikki.vesanto/.qgis2/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\Program Files (x86)\ArcGIS\bin', 'C:\OSGEO4~1\bin\python27.zip', 'C:\OSGEO4~1\apps\Python27\DLLs', 'C:\OSGEO4~1\apps\Python27\lib', 'C:\OSGEO4~1\apps\Python27\lib\plat-win', 'C:\OSGEO4~1\apps\Python27\lib\lib-tk', 'C:\OSGEO4~1\bin', 'C:\OSGEO4~1\apps\Python27', 'C:\OSGEO4~1\apps\Python27\lib\site-packages', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\PIL', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\win32', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\win32\lib', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\Pythonwin', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\OSGEO4~1\apps\qgis\python\plugins\fTools\tools']

Traceback (most recent call last): File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 182, in loadPlugin import(packageName) File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Users\heikki.vesanto/.qgis2/python/plugins\processing__init__.py", line 29, in from processing.tools.general import * File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:\Users\heikki.vesanto/.qgis2/python/plugins\processing\tools\general.py", line 29, in from processing.core.Processing import Processing File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\core\Processing.py", line 35, in from processing.gui.AlgorithmExecutor import AlgorithmExecutor File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 453, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: No module named AlgorithmExecutor

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version: 2.0.1-Dufour Dufour, d94c044

Python path: ['C:/OSGEO4~1/apps/qgis/./python/plugins\processing', 'C:/OSGEO4~1/apps/qgis/./python', 'C:\Users\heikki.vesanto/.qgis2/python', 'C:\Users\heikki.vesanto/.qgis2/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\Program Files (x86)\ArcGIS\bin', 'C:\OSGEO4~1\bin\python27.zip', 'C:\OSGEO4~1\apps\Python27\DLLs', 'C:\OSGEO4~1\apps\Python27\lib', 'C:\OSGEO4~1\apps\Python27\lib\plat-win', 'C:\OSGEO4~1\apps\Python27\lib\lib-tk', 'C:\OSGEO4~1\bin', 'C:\OSGEO4~1\apps\Python27', 'C:\OSGEO4~1\apps\Python27\lib\site-packages', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\PIL', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\win32', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\win32\lib', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\Pythonwin', 'C:\OSGEO4~1\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\OSGEO4~1\apps\qgis\python\plugins\fTools\tools']

Should be reported on: https://hub.qgis.org/projects/sextante/issues

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.