2

Using ArcGIS 10.2 and Personal geodatabase,I have a field with values of Numbers like 0.461538 and Type of "Double".

How can I Export them to new Field in Percentage Format to be shown like 46% or at least round the number to looks like 46 then I can add "%" on label to them?

(Honestly! I do not think this is a good idea for further Analysis!).

  • Having the % on the end for display is fine but if you need to run analysis on that field it should stay as a number. – Nathan W Jan 3 '14 at 2:58
  • 1
    You will have to do this in a text field since % signs aren't allowed in numeric fields – user681 Jan 3 '14 at 3:05
  • So how can I generate Percentage Field in ArcGIS? – user1106951 Jan 3 '14 at 3:09
  • Which version of ArcGIS for Desktop are you using to try and do this? – PolyGeo Jan 3 '14 at 3:33
  • Also, is your data stored in as shapefile or some other format? – PolyGeo Jan 3 '14 at 4:05
5

you should rather change the display so that you don't duplicate your field.

1) Open your attribute table

2) right click on the name of your field

3) select "properties"

4) Press the icon next to "numeric"

5) select percentage : the number represent a fraction

6) go to the option for rounding (number of decimal places set to 0 )

enter image description here

2

If you need this for labeling purposes only, leave the field as it is and label your features using this expression (with the VBScript parser):

round([Test]*100) & "%"
2

Use the following in your field calculation with the Python parser:

round(!yourFieldHere!, 2) * 100
  • Thanks Aaron, but This is not working I tried both round(!Test !, 2) * 100 and round(![Test]!, 2) * 100 but not working – user1106951 Jan 3 '14 at 5:04
  • Could you walk me through the steps you used to calculate a new field? – Aaron Jan 3 '14 at 5:10
  • Ok I have a Field in Double Type format and it's name is "Test" I Added a New Field to table called "Res" this time in "Long" format. and used your code to calculate the field – user1106951 Jan 3 '14 at 5:12
  • I just double checked and it worked for me in long, text, float and double. Make sure the Python parser is selected at the top of the field calculator. Also, you may need to replace !Test! with !Test_!. – Aaron Jan 3 '14 at 5:20
  • !Test! is the syntax with Python and [Test] is the syntax with VBA. You need to change the parser to Python in order to use Aaron's code. – radouxju Jan 3 '14 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.