0

This question already has an answer here:

I successfully installed QGIS 2.0 on my macbook running OSX Mavericks, but when I attempt to open the program, I get the following message: "QGIS cannot be opened because of a problem. Check with the developer and make sure QGIS works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application and OS X."

As far as I can tell, everything is updated and I reinstalled QGIS twice with no luck.

Problem details and system configuration: Process: QGIS [1087] Path: /Applications/QGIS.app/Contents/MacOS/QGIS Identifier: org.qgis.qgis2 Version: ??? Code Type: X86-64 (Native) Parent Process: launchd [132] Responsible: QGIS [1087] User ID: 501

Date/Time: 2014-01-06 17:36:06.120 -0500 OS Version: Mac OS X 10.9.1 (13B42) Report Version: 11 Anonymous UUID: FC49D1E1-1069-09AE-FE37-E5ADF06A6277

Sleep/Wake UUID: 03863BF4-29D6-4A54-A415-DD0D62750EEF

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Library not loaded: /Library/Frameworks/PROJ.framework/Versions/4/PROJ Referenced from: /Applications/QGIS.app/Contents/MacOS/QGIS Reason: Incompatible library version: QGIS requires version 8.0.0 or later, but PROJ provides version 7.0.0

Binary Images: 0x7fff6b7f7000 - 0x7fff6b82a817 dyld (239.3) /usr/lib/dyld 0x7fff87216000 - 0x7fff87280ff7 com.apple.framework.IOKit (2.0.1 - 907.1.13) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit 0x7fff8f37e000 - 0x7fff8f37efff com.apple.ApplicationServices (48 - 48) <3E3F01A8-314D-378F-835E-9CC4F8820031> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices 0x7fff90e77000 - 0x7fff9105cff7 com.apple.CoreFoundation (6.9 - 855.11) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

Model: MacBook5,1, BootROM MB51.007D.B03, 2 processors, Intel Core 2 Duo, 2.4 GHz, 2 GB, SMC 1.32f8 Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB Memory Module: BANK 0/DIMM0, 1 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142323837344448312D4346382020 Memory Module: BANK 0/DIMM1, 1 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142323837344448312D4346382020 AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.106.98.100.22) Bluetooth: Version 4.2.0f6 12982, 3 services, 23 devices, 1 incoming serial ports Network Service: AirPort, AirPort, en1 Serial ATA Device: TOSHIBA MK2553GSX, 250.06 GB Serial ATA Device: MATSHITADVD-R UJ-868 USB Device: Built-in iSight USB Device: BRCM2046 Hub USB Device: Bluetooth USB Host Controller USB Device: Apple Internal Keyboard / Trackpad USB Device: IR Receiver Thunderbolt Bus:

marked as duplicate by PolyGeo, Jason Scheirer, whuber Jan 5 '14 at 22:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome on GIS SE. Please check first if gis.stackexchange.com/questions/44393/… does not contain the answer to your question – radouxju Jan 5 '14 at 21:10
  • You dylib error indicates you may have upgraded a Kyngchaos.com QGIS install and not upgraded its underlying GDAL and GSL frameworks. GDAL Complete framework must be the latest 1.10, and GSL helps with some aspects of the georeferencer plugin. Besides Python modules (psycopg, numpy), those are the only frameworks now required. (Btw, this is all in the Kyngchaos installs' READMEs.) – dakcarto Jan 8 '14 at 0:02
1

I've just set up QGIS 2.0 on Mavericks, rather than upgraded, but see no reason why the process would be any different.

KyngChaos maintains the Mac version of QGIS (linked to from the QGIS site in case you're worried).

You need FreeType for Matplotlib. Ensure you download and install that first: http://www.kyngchaos.com/software/frameworks

You can then download Matplotlib python module from from: http://www.kyngchaos.com/software/python

Let me know if that works or if you still receive errors.

  • Installing Matplotlib worked, thanks! Unfortunately, after installing QGIS 2.0, I get an error when trying to open the program (see my modified post above) – user25471 Jan 7 '14 at 16:16
  • @user25471 - Try reinstalling the latest version of the GDAL framework from KyngChaos. Make sure you use version 1.10 (the present latest version). You may need to uninstall QGIS before updating the framework, then reinstalling it. – Phil Jan 9 '14 at 9:25
0

I've tried reinstalling Python numerous times

Why ?

Python is installed in Mac OS X (look my answers in QGIS Python version)

The only thing you need is, as radouxju says, to install the matplotlib version of KyngChaos or other version of matplotlib, as long as the name of the resulting folder is matplotlib in the site-packages of the Apple Python (in /Library/Python/2.7/site-packages, where numpy is installed: numpy-override folder)

Not the answer you're looking for? Browse other questions tagged or ask your own question.