4

I'm registering a table w/ native geometry with the geodatabase and it is taking a long, long time. Actually I'm not sure if ArcCatalog is frozen or crashing. The table does have several million features (points).

The database is a SQL Server 2012 database and there is nothing happening on the database when I run SQL Profiler so whatever is going on, I think it's on the client. What is ArcCatalog (10.2) doing that is making it slow. Is there a way to make it go faster?

2
  • Several million points may be the problem. Can you split up the data into smaller chunks? – whatahitson Jan 6 '14 at 17:42
  • I know this has worked in the past, but I don't remember which ArcGIS/SQL Server version combination it was. <5 million is big but not crazy big. – Jay Cummins Jan 6 '14 at 21:01
3

The registration process has several small activities (storing column names and types) which are relatively fixed in duration (milliseconds) and table scan activities which test for uniqueness in the regsitered rowid column and topology class consistency (all point, or all line, or all polygon of the same dimensionality), which are dependent on the number of rows in the table. I forget whether it does simpleline and/or polygon validation (which wouldn't apply to points, anyway).

If nothing is happening on either side, then it would appear that a crash has occurred.

You can limit the table scan activities by registering nearly-empty tables (one representative row, for geometry type identification), then loading the real rows afterward, though doing so exposes you to runtime errors if the rowid column is nonunique or the topology class is wrong.

2
  • That worked--I registered a single row table (so the registration tool would know the geometry was point, otherwise it would fail since it didn't know if I wanted pt/line/poly). – Jay Cummins Jan 6 '14 at 20:51
  • 'sdelayer -o register' doesn't need the type, since it's a parameter, but loading one row will keep geodatabase tools happy; I'll update the answer. – Vince Jan 6 '14 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.