0

I am running OpenSUSE 13.1 and downloading via Yast I get the following error: nothing provides libpq.so.5()(64bit) needed by qgis-master140102-1.2.x86_64

I get three of these errors, for each of the three qgis downloads (master, grass plugin, master-devel).

I have two options under Conflict Resolution: 1-do not install... 2-break...by ignoring some of its dependencies

What would you folks recommend? Is there something wrong with QGIS in openSUSE?

  • libpq is usually from PostGIS or PostgreSQL. What's the output of zypper wp libpq.so.5? – SaultDon Jan 7 '14 at 19:05
  • unfortunately I don't understand your question. Should I input that somewhere? – Oregonian Jan 7 '14 at 19:16
  • Sry, you have to enter that into a terminal (command line). I'm not sure if you can check for what-provides using YaST Software Manager - but I know zypper. – SaultDon Jan 7 '14 at 19:54
  • I put it into the terminal and it said: Loading repository data...reading installed packages...No packages found. – Oregonian Jan 8 '14 at 0:42
  • What if you change just libpq.so.5 -> libpq.so? – SaultDon Jan 8 '14 at 0:46
1

It looks like one of your main repos is disabled; just has to be enabled.

I can see that in the output of zypper lr -u.

#  | Alias                     | Name                               | Enabled | Refresh | URI                                                                      
---+---------------------------+------------------------------------+---------+---------+--------------------------------------------------------------------------
 1 | google-earth              | google-earth                       | Yes     | Yes     | http://dl.google.com/linux/earth/rpm/stable/x86_64                       
 2 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | Yes     | hd:///?device=/dev/disk/by-id/usb-Generic_Flash_Disk_13E8F75D-0:0-part2  
 3 | openSUSE_13.1             | openSUSE_13.1                      | Yes     | Yes     | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_13.1/
 4 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     | http://download.opensuse.org/debug/distribution/13.1/repo/oss/           
 5 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     | http://download.opensuse.org/debug/update/13.1/                          
 6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     | http://download.opensuse.org/debug/update/13.1-non-oss/                  
 7 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     | http://download.opensuse.org/distribution/13.1/repo/non-oss/             
 8 | repo-oss                  | openSUSE-13.1-Oss                  | No      | Yes     | http://download.opensuse.org/distribution/13.1/repo/oss/                 
 9 | repo-source               | openSUSE-13.1-Source               | No      | Yes     | http://download.opensuse.org/source/distribution/13.1/repo/oss/          
10 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     | http://download.opensuse.org/update/13.1/                                
11 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     | http://download.opensuse.org/update/13.1-non-oss/

In your case, just run sudo zypper mr -e repo-oss then you can run sudo zypper ref and finally sudo zypper in qgis-master.

It's actually probably really easy to "enable a repo" in YaST Software Manager too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.