I have a parcel fabric layer that has a gap in it:

enter image description here

I want to edit the selected parcel on the bottom to fill the gap. I don't want to construct a new parcel to do so. How do I modify the parcel in such a way that it maintains its attributes and fills in the gap with the parcel above it?

Based on answers and comments, I created a topology and placed the parcel fabric inside it. It appears that you cannot use topological tools to edit a parcel fabric. As such, any answers using topology will not work.

  • I believe there is a zipper tool, though I'm not familiar with the parcel network editing scheme.
    – Elliott
    Jan 7, 2014 at 20:36
  • Are you using topology? If so there is a method.
    – Elliott
    Jan 7, 2014 at 20:40
  • I don't currently have the parcel fabric participating in a topology, though the parcel fabric can be placed in a topology that has parcel fabric rules easily as it still passes all of the original six topological rules necessary to import data into a parcel fabric (aside from this above exception).
    – Conor
    Jan 7, 2014 at 20:41
  • To elaborate on this - it is my understanding that the parcel fabric has a "built in" topology. Do you mean using another topology above and beyond this like in my above comment?
    – Conor
    Jan 7, 2014 at 20:51

4 Answers 4


Using topology, the two features can be easily hemmed together using the Topology Edit Trace Tool and the Reshape Edge Tool, both found on the Topology Toolbar.

Note that in this example, unselected nodes are symbolized, which is found in the editing options on the Topology tab (pic). This is optional but helpful.

Your data (approximation): Example data

Step 2. Using the Topology Edit Trace Tool, click the map window once to initial topology (and show unselected nodes). click once

Step 3. Click once and release on the line to be adjusted, and then move the mouse along the path that is to be adjusted. click and move

Step 4. The path becomes pink. Click the Reshape Edge Tool. Reshape edge tool

Step 5. With the Reshape Edge Tool selected, draw the corrected path for the line. In this case, another arc is drawn along the entire arc length. Any sketch tool is possible here. draw new line

Step 6. The sketch paths are overlapping. This effectively closes that gap. There will be a line overlap that would ideally be subtracted. Done

Note that if there is a feature in the gap, which will be zeroed out by this process, ArcMap will return an error.

  • Thank you for this timely, thorough and detailed answer. It unfortunately appears that you cannot edit a parcel fabric with topology tools. A topology can be used to validate rules, but no edits can occur with topology tools. Nothing is selectable in the parcel fabric with topology tools. Nodes do not appear and no "shared features" are available from the topology tool. Thus, your answer will not solve my problem.
    – Conor
    Jan 7, 2014 at 22:25

Use the Align Edge tool. Click on the side you want to have moved, then click on the side you want it to snap too.

Make sure both feature classes are part of a topology.

  • Thank you for your answer. It appears that you cannot use topology tools to edit a parcel fabric. As such, this answer will not work for me.
    – Conor
    Jan 7, 2014 at 22:32

Since editing the fabric through a topology is a no-go, I've explored other options and found a workaround.

First, some background:

Optimally, you should be directly able to edit a parcel's COGO attributes to eliminate slivers and gaps in your parcel data such as in my situation above. ESRI for whatever reason does not want this (If you open a parcel for editing all current COGO attributes are in grey).

Instead ESRI wants you to construct brand new parcels from parent parcels each time. However, if you do this, you have to retype every single one of your attributes in the new child parcels that are created from the parent. There is currently no way to inherit them from your parent parcels. Obviously, we can't be retyping the parcel attributes for 2-4 parcels every time a minor edit is made. Plus, then we'll have a bunch of historic parcels floating around that really shouldn't be historic.

Another suggested option is to rejoin the parcel to the fabric such as in this boundary line adjustment video. It sounds pretty easy and great, but it doesn't really work for whatever reason.

What they want you to do for the rejoin:

enter image description here

The janked up result:

enter image description here

Now for something that actually works:

This solution is not optimal, but seems to be the only viable workaround at the moment.

  1. Go to Parcel Editor - > Plan template.

  2. Right-click whatever plan your parcel that you want to expand is in (for me it was the default, ).

  3. You want to construct a brand new parcel, so click Construction....

  4. Create a brand new parcel that fills up the hole exactly, using radius/chord if you need to. Finish that polygon (don't bother with any attributes)

  5. Select your new parcel and the old one and merge. Now you get the choice of inheriting attributes from a parent polygon (why didn't you include this in Construct from Parent, ESRI?).

  6. Select your old polygon and voila, you now have a complete polygon.

  7. Go into your historic data and delete the "gap" polygon if you don't want it hanging around


During an unrelated support call with ESRI I learned of a better way to resolve these gap errors, the Mean Points Tool:

The Mean Points tool Mean Points on the Parcel Editor toolbar can be used to merge and find the average coordinate of a group of points that lie within a specified tolerance of each other. Drag a box around the points you want to merge, type a tolerance in the Mean point tolerance text box, and click OK to merge the points.

enter image description here

To solve this specific issue you would select the opposite points that exist on either side of the gaps you want to close, and the lines will merge.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.