I am trying to install import files to cartodb installed on local machine. But import fails with these errors like

Error 2001 unable to load data
Error 3009 SHP normalization error

Also the ruby console says the ogr2ogr error. So tried to update gdal-bin 1.10.x. Current version of gdal-bin is 1.9.2. But during the sudo-apt get install gdal-bin, these error appears

gdal-bin : Depends: libgdal1h (>= 1.10.0-1~precise1) but it is not going to be installed

Tried to add gdal 1.10 ppa to system. Also removed older version. But not successful.

1 Answer 1


About the 1.10 gdal upgrade:

It seems that you have some conflicts (probably a program depends on the lib). Don't worry you can use aptitude which will create a solution fo your conflict and try to repair it.

sudo apt-get install aptitude
sudo aptitude

In case you are wondering, apt-get is a striped down version of aptitude, excellent for everyday usage but lucks versatility of aptitude.

  • Solved. Installed/updated some packages gdal-bin 1.9 libgdal1-dev 1.9 python-gdal 1.9 ogr2ogr --version 1.10
    – user
    Jan 8, 2014 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.