1

I'm very new to this so please excuse my ignorance.

I've been working with OS data and my own shape files and had no problem with print composer. Suddenly my OS gridlines are not appearing properly. Some are there, some aren't. The map is fine until I go into print composer.

What have I done wrong?

Thanks

  • Actually they are messed up pre print composer I see now. It was all fine yesterday. What have I done? – Kat Jan 8 '14 at 12:05
  • Check the map canvas - are they showing up at all? or are they showing up in a different place to where they were before? – Neil Benny Jan 8 '14 at 12:17
  • Another thing to check is in the print composer -> Item Properties for the map -> is the "Lock layers for map item" option ticked? This will stop layers from being added in or removed. You may need to untick this. – Neil Benny Jan 8 '14 at 12:19
  • Thanks Neil. That option was unticked. Hasnt fixed it I'm afraid – Kat Jan 8 '14 at 12:23
  • Did that fix it Kat? – Neil Benny Jan 8 '14 at 12:24
1

It sounds like your problem is to do with the OS raster product drawing at the wrong scale. You'll find information about recommended scales on the OS website. Effectively showing the 250k mapping product at a whole UK level would cause QGIS to simplify the data and you will lose some of the detail of the map, including the grid squares. You might want to think about the scale of the mapping you are using.

There are a couple of things you could do.

1) In the composition section of the Print Composer you'll see there is a resolution option under "Paper and quality" - you can increase this a bit and that may help a little when you export the data to a graphic or pdf.

2) You could manually put in the grid lines using the "Show Grid" options in the item properties of the map.

3) You could try to do something with the pyramid options which you will get if you right click on the raster layer and click on the "Pyramids" option - try a different resampling method and see if that helps.

4) Download the OS Vector datasets for the mapping you want to use and use these to display the data.

  • Thanks for all these suggestions Neil. I'll work through them. – Kat Jan 8 '14 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.