0

I am trying to geocode a list of addresses to location in a particular shapefile which has roads. I'm using ArcGIS 10.1, and trying to geocode using the address locator 10.0 north america geocode service (in table of contents, right click on the file -> geocode address).

The spreadsheet that I am trying to geocode is in .xls format. The geocoding MATCHED ~640 cases, before it gave this error:

Creature Feature Class/Error processing the table

There are no unusual characters in the field names - all of them either have a letter or a number, and nothing else.

Scanning over the spreadsheet, there do not appear to be any null values, and the addresses do not seem to contain any periods, or characters that would otherwise be unacceptable to an address locator (my thoughts on the matter obviously).

I've looked over other problems of a similar nature that have been posted in various forums, and most of the answers seem to be that the problem lies in the data, or in the format of the data.

So my questions are:

  1. Is there a specific problem with the data that I should look for?
  2. Why would the address location terminate after ~640 successful matches?
  3. Is there a better way to place point representation on a map, rather than geocoding a list of addresses via address location to a shapefile?
  4. Could the problem be with the shapefile, and some of the shapefiles attributes?
  • Also, is there a problem with my choice of address locator? – user3097236 Jan 10 '14 at 1:35
  • Would you be able to include a graphic showing the source data of the last few addresses that went in, the first one that did not, and perhaps the next couple after that, please? – PolyGeo Jan 10 '14 at 1:52
  • I kept running the address locator, and afterwards it crashed at 991 addresses, and then successfully matched everything! Only there is a problem with the match - it geocoded an array of addresses to two locations! The problem doesn't seem to be any more that the address locator can't match address to locations, but that it only matches addresses to one of two locations. Also, how do I attach or post files to questions/comments? @PolyGeo – user3097236 Jan 10 '14 at 2:21
1

Sometimes when I geocode large tables (millions of records) I get the same error. I have been keeping an eye on my RAM during geocoding and it seems to be when I run out of memory, this error occurs.

In the locator properties there is a performance category, I tuned down the data cache size and get the error less, albeit geocode a bit slower.

I have also noticed the error a lot less when I run the 'Geocode Addresses' Tool, versus just right click geocoding.

Hope this helps!

  • I tried the geocoding address route: – user3097236 Jan 10 '14 at 14:13
1

I created my own address locator, using a dual ranges style, as well as matching up the proper variables from the spreadsheet and the input layer, and now, not only do the addresses become matched almost instantly (~10 seconds maybe as opposed to 5-10 minutes it took through the right click-> geocode addresses method) but it actually worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.