Probably there is a very simple solution to my problem - I just can't find one! I have a point shapefile with x, y and z data - I can display it in arcscene but it is flat - the z data isn't being used! How can I direct arcscene to the z field in my attribute field so that it displays points at different levels?!

  • In the properties window there is an option which says "Layer features have Z values. Use them for heights", but it is greyed out. I converted my point shape to a layer but it was still greyed out! – Alice Apr 7 '11 at 9:44
  • Did you try posing this on the ESRI forums? Most posts get ignored but interestingly some receive a lot of attention from ESRI staff. – Jakub Sisak GeoGraphics Apr 7 '11 at 13:18
  • I have followed your advice and posted it on the ESRI forum! i will link back here if anyone answers it! – Alice Apr 7 '11 at 13:54
  • posti inside the 3D Analyst forum: forums.arcgis.com/forums/97-3D-Analyst – Jakub Sisak GeoGraphics Apr 7 '11 at 14:08
  • Setting the base height from an attribute in ArcScene - help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/… – Mapperz Apr 7 '11 at 15:02

I would guess that your layer is not a 3D layer. You can check your layer attribute table. If the Shape field just says "Point" for each record you just have a 2D layer. You can use the 3D Analyst>Convert>Features to 3D tool to make your layer 3D. Once you have done that, open the table and look at the Shape field. It should now say "Point ZM", and the "Layer features have Z values" option should be active now.

  • I've experienced similar problems with what Alice is describing in version 10. Options that were available in the properties in the older versions (such as described in her comment) are grayed out. If Z value exists as an attribute it should be possible to display data using the attribute. – Jakub Sisak GeoGraphics Apr 7 '11 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.